Intermittent HDMI signal loss! Help!

The newly purchased WD TV live is connected to my Sammy LCD (LA32B5307PR) through HDMI. Firmware version is 1.02.21

Now at random intervals, there is a loss of video signal (blackout) and most of the times, a message is displayed - “Searching for signals”. Sometimes every min. Sometimes once in 5 -10 min. Sometimes the frequency goes on increasing. Could not understand the pattern. The audio is still heard all the while.

Though this is for a very brief moment 1-2 seconds, it is very annoying. Everything is ok when component or composite connection is used. Problem only with HDMI (all 3 ports). Not only when watching 1080p videos, even during music playback. 

I am not sure if it is a problem with the TV. Samsung’s service engineer is coming today. But suddenly I felt problem might be with the player. How to rule out this possibility assuming that I currently don’t have any other HDMI source or a spare HDMI cable? Pls help!

Welcome to the forums.

First, you definitely need to try another HDMI cable – not all of them are created equally, and I’d actually get a cable that’s 1.4 certified because that’s a quality cable to test (if you live near a Best Buy you can get one and return it if it doesn’t make a difference).

Next, the Live IS sensitive to Handshaking issues – that’s where it “talks” to the display device to determine what it can support.  Cable might solve those problems, and in general it’s not Samsung that have those issues (my Sammy works just fine) but if so changing it from “auto” (the default) to a particular resolution (like 1080p) may solve it.  Go into the Audio/Video menu, select HDMI and then select a manual resolution to see if it solves the problem).

1 Like

Sorry, but these suggestions have not helped me in two HDTVlive.

The players have to work until my Technisat HD Vision 32 and then suddenly, without firmware change any more.
I have tried other HDMI cables 1.3 and tested on mkelley’s proposal also cable HDMI 1.4. This has all helped.

I’ve done TV and player one days normally, has not helped and also the cutting of 2 mm insulation has brought nothing, if the plug does not extend far enough into the player.

The handshaking between Media Player and some types of TVs will not work or it works without an apparent reason not working after a certain time.

The manufacturer Western Digital should finally result in a list and make known, in which the devices are listed, to which the media player is not kompatiel.
A list could be safely initiated on this and other forums.

The manufacturer could also try to explore why and how it comes to this error.
He should be the one guaranteed to be either the device compatibility, or to inform customers about the restrictions.

The fault can not be sought at the TV producers, because with my device and my cable handshaking works so far with all other connected devices.

Its not helpful to cross post.

My problems with hdmi handshake went away with Beta firmware v1.03.40_v. I had blackouts with the official firmware v1.02.21.

My Tv is a Samsung LE40B550 paired with the WDTV Live and the Denon AVR1911 between them :slight_smile:

Sorry not not updating. Could not find time for troubleshooting this problem.

Thanks MKelly. Though  changing the resolution did not help, reducing the  frequency to 50hz seem to have solved the problem. I cannot be absolutely sure as I did not check it for more than 5 min. Will do a thorough checking and post the updates.  If it does not work, then I will try downgrading the firmware as jctavares suggested, before I check with a different HDMI cable…    Appreciate the assistance given. 

not downgrading, upgrading :slight_smile:

^^ Thanks. Will try upgrading if problem persists. Does the release notes of this beta mention anything about this handshake problem?

That version was a VERY LIMITED RELEASE to SPECIFIC INDIVIDUALS (less than 20 were asked to use it.)

But, obviously, it went “Wild” on its own.

It is SPECIFICALLY for HDMI troubleshooting.

And you should be aware it has OTHER issues which you may not want to deal with right now.

As always, any BETA firmware release is “use at your own risk” – and don’t complain here if it doesn’t work for you.

What I can say is that I needed to upgrade to the Beta v1.03.40 to solve the HDMI issues. As MKelley says, this is a BETA firmware, use it at your own risk.

Limited Public Betas:

Version 1.03.40_V Limited Public Beta

 - Resolved FW not completing upgrade for certain TVs

Version 1.03.39_V Limited Public Beta

  • Resolved HDMI screen flicker issue

  • Resolved playback issues related to mkvmerge.

  • Improved thumbnail caching

Version 1.03.38_V: Limited Public Beta

  • HDMI handshake issues introduced in 1.03.35V

Version 1.03.35_V Limited Public Beta

  • Resolved MP4 problems with seeking and audio stopping.

  • Resolved MP4 poor frame-rate and audio out of sync.

  • Resolved File Share group name – No longer requires all group names to be the same. (Reset to factory defaults required)

  • Resolved various user interface translation issues.

Version 1.03.22_V Limited Public Beta

  • Added Mediafly application.

  • Added DVD Navigation support.

  • Added .MOV chapter support.

  • Added wireless adaptor support for ASUS USB-N13.

  • Added security when mounting a network share on password protected local drives.

  • Resolved aspect ratio issues.

  • Resolved subtitle encoding for Big 5

  • Resolved resume remembering previous audio selection.

  • Resolved IDX +_SUB positioning issue causing video freeze.

  • Resolved PGS subtitle becoming frozen while using the delay function.

  • Resolved Network share intermittent detection issue.

  • Resolved undetectable 4TB My Book.

  • Resolved large capacity video file (.ts) unable to play issue.

  • Resolved DVR-MS video stops when fast forward at 6x.

  • Resolved Buffalo G300N not enumerating.

Resolved undetectable 4TB My Book?    Here I thought that WD had said several times that 2TB was the max supported…


Maybe it’s only the MyBook that’s supported.

The possibility is that there is still a 2TB limit but because the MyBook is undoubtably just 2 2TB drives chained together it’s possible in that particular case it’s supported (who knows better than WD how their stuff works?).

I’m checking on this as we speak.

As I’ve been just told: “Only the original wdtv had a 2tb limit. All products since then support larger volumes.”  Go figure. 

Really?  Hmmm – that’s *very* interesting.

So just so we’re clear here – we’re talking all versions of the Live and Plus, correct?  No particular firmware update needed?

mkelley wrote:

Really?  Hmmm – that’s *very* interesting.


So just so we’re clear here – we’re talking all versions of the Live and Plus, correct?  No particular firmware update needed?

Correct. There was a bug related to a 4TB My Book, but I think it was specific to the My Book’s firmware and not to the volume size.