Intermittent Access to Drive and UI

Just recently my WD MyBookLive 2TB drive has been playing up - its getting harder and harder to access the shares on the drive.

The content is all still there, i get occassional access to it and i’m trying to access it internally via iPad, Windows 7 and 8.1

I’ve changed all of the physical variables that i can - the port in the router, changed the location of the drive, its now in a network hub nearer the desktop that i’m trying to connect through and changed the cable so am left with the decision that the interface between network and drive is faulty, ie inside the drive itself.

It hasnt got the latest firmware on it, it advised me today that that was available but i daren’t attempt it with the drive in its current state.

today for the first time in over a week it let me log in to the UI but after logging in it now gives me fault codes or times out.


33161 - Error retrieving share information: Your last operation timed out. Make sure there are no network connectivity issues and try again.


30005 - Unable to retrieve data. Make sure there are no network connectivity issues and try again.

what can be done to solve this? i’ve had it since September 2012.


I am having the same issue and the amount of time the device is inaccessible is increasing. When it does work, it is without any apparent change of any sort. Any help would greatly appreciated.

Hello teheran, Mmmurry,

Have you tried setting the device with a static IP.  This should help you to have a better connection to the unit.

Also you can try resetting the unit and the devices on the network to refresh the connections.

Thanks for your reply, Yes I have tried everything you have suggested which is why I have come to the conclusion that the hardware is at fault.

thanks Help4All but I have indeed tried all those things. It has always had a static IP and I have reset the system many times.

I found the WD on my network yesterday and it seemed to work fine. Today with no changes at all other than turning off the computer (not the WD drive) I come back to it and it is not there. Do I need to buy another drive and tranfer all the data as a matter of urgency? If I lose that data (it is 88% full) I will be in severe trouble.

PS The web page interface is usually there, even when using Ubuntu or iPad, although not always. It is the drive on Windows networking that is proving so unreliable.

thats strange, mine was at 90% full when it started playing up.

looks like i’ll be buying a different brand hard drive as a replacement and paying someone to transfer the data for me. great! just what i need.

Hello Help4All and others,

I am having the same issues with accessing the drives and the UI probably failing. I have two WD 2 TB MBL and one 4TB WD MBL Duo. The intermittent access has been an ongoing hassle for two of the drives since day one but the UI was reliable until the past month or so. I cannot tell you what firmware they have since i was checking this through the UI and that screen does not populate now but they were set to automatically update so they may be updated as of today (3-28-14)… ? Who knows.

My drives’ UI allows me to login normally when i go to the drive’s URL (192.168.0.X/UI/login) the UI shell is there with the tabs on left and black background with the logout in top right but that’s it…nothing in the middle. Also some pages do not populate when i click the tabs on the left. I am able to see the Users / Shares / Support pages like normal; however, the Settings and Safepoint pages when clicked shows “please wait” and either stalls or acts like it goes there but nothing populates… I looked at where the links were supposed to go:

Settings page -   /UI/Settings

Safepoints page - /UI/Backups

Versus where they are going:   /UI/#  

teheranMmmurry, Are you finding this to be the same on yours?

If so this may be one issue we are having with the UIs. I saw you both had drive usage over 85% however, my drives are showing a usage of 10% - 50% so it doesn’t seem to matter the usage amount. Also, when i try to do a drive check either quick or full i get an error of : 

31349 - Error starting diagnostic test: The operation was aborted while the server was processing the request. The operation may or may not have been completed successfully. Please refresh the page and try again.

I also get another error when i try to do anything else from the UI such as add a user, change user info, modiy the shares. I’m currently copying all the contents of the drives to yet another drive just in case they crash soon so i cannot get the error code until the copy is done. 

I have been able to get around part of the UI issue and get to the Settings and the Safepoints page by typing in the URL… The UI background and most other items of the UI are gone but when I click on the next item such as System (/UI/Settings/System) or Network /UI/Settings/Network) link it populates correctly back in the UI but the black background is gone and shows white. I will check my Live Duo tomorrow. I clicked on reboot for so far two of the three drives and this did nothing to improve the issue… just wasted 30 mins. I have power cycled my network and computers with no improvement as well wasting another 45 mintues. See previous “annoying” comment above. :) 

The drives were purchased b/c they allowed access from PC or Mac. I have 3 PC laptops, 2 Macbook Pro 8,2 i7 Quad Core Intel laptops one with 8G-RAM/500G-HDD and 16G-RAM/750G-HDD, two iPads and two iPhones which all need access to these drives. 

I have found over the past year that the My Book Live NAS drives work well when there is only one MAYBE two drives attached to the same network that you rarely have to access. The drives, though they may be MAC compatible, they are not very nice to iPads and iPhones in general.

One drive allows connecting just like a HDD on my computer and works great. I click on the drive, it populates immediately, i got on the share to folder then file, bam… easy and done…  but the other two are flat out annoying… i click on the drive, it times out, the drive disappears from my network completely or they will show up as a Mac one minute and then disappear again and show up as PC… In order to access these two drives I have to connect them like a server every single time i go to the drive to open a file, which is disappointing and VERY annoying.

I have tried to access the drives via WD My Cloud app on my Laptops and only one of the drives will show up at a time… (seems to be randomly selected) but may be whichever first responds to the initial ping from the program. There is a spot that shows other drives on your network… but the other two does NOT show up. I have tried using the drive as static IPs and DHCP… the static IPs work best but still has the drive connectivity as having to remount every time you want to open a file on the drive. After dealing with the connection issues with the drives for so long i found the most reliable configuration has been to have the drive’s settings as DHCP but the router set to assign IP address for these three devices by Mac Address. This way the drive will accept whatever address it is given but always has the same IP and still allows for remote access.  

I figured this out becasue months ago I had the drive setttings set to Static IP and I upgraded the speed of my internet so i got a new router that was compatible with the new modem… Well, i forgot to change the settings of the drives and they revolted against my network by giving it the silent treatment. After pinging the network and looking at the routing table i noticed that both drives had the same IP address on the same subnet mask…  which is not supposed to be possible… it was a total mess. Neither would show up on my filesystem, through the WD Drive setup, WD My Cloud, or the, etc., I was able to go around the IP address issue and access the drives via node name (Example: MyBookLive1.local or MyBookLive2.local). I changed the Drive network settings from Static to DHCP and rebooted the network… 

So… i have three drives two with drive accessing issues, and two with UI issues. I have not tested the third drives UI but like i said i’ll do that later after drive backups are done. 

To solve this issue I ended up buying a DLink sharecenter NAS enclosure box.

First of all I had to mount the WD hard drive in my PC using some free Linux based software I found on other forum posts and copied all the data I wanted to keep on to a PC. - it was great having a digital clear out!

Then I installed the drive in the new box, it reformatted it and I copied all the content back over and it’s now working again.

Took all weekend and cost a few quid (£60 for the DLINK box) but have now got fast access to all my data and spare space for an additional drive should I wish to have additional storage or set it up as a RAID device - which in still learning.

This may not help you guys but I decided my interface was goosed and we were getting no help here!

1 Like