Intel Matrix Storage Manager


#1

Hello,

I have a My Book Studio Ed. II 2 gig version.  I have it set up with Raid 1.  I set it up an a Windows Vista machine about 6 months ago and I used the included Western Digital software (reformatted for Win and set to RAID 1).

Since then I have switched to a new machine that is running Win 7 64bit.  I now connect with e-sata port and this new machine has Intel Matrix Storage Manager present.  I don’t know if I need this software but my new dell included it for some reason…

When I first plugged it in the Intel Matrix Storage manager said it was going to be used to manage the drive (I had not installed the WD software yet).  The weird thing is that the Intel Matrix software does not see the device as a RAID device.

I then tried installing the WD software but I cannot launch it for some reason and the WD icon does not appear in my sys tray.

I think the drive is working properly and I can read and write to it but it does seem to slow down my computer a lot.  It hardly ever sits idle when I am using the computer and often makes noises as if the dive is seeking ( every 10 sec or so)

Can any help me with the idea that the Intel Matrix Software is somehow conflicting with the drive?  Why doesn’t the WD software seem to work?

Other notes;  I cannot eject the disk.  If I try it connects again right away.  The other weird thing is that I think maybe my user profile is some how linked to the disk…  If I try to boot the PC with out it attached it says that my desktop could not be found.

Sorry for the long post but if anyone can assist I would appreciate it.  Regards, DDEO


#2

I have the same problem! I own a Dell M6400 with Intel ICH9M-E/M Sata Controller (Intel Matrix Storage Manager version 8.9.2.1002)  When I try to connect my Western Digital My Book Studio 1 GB (no Raid) to the external eSata Port the System (win7 64bit) does not recognize the drive! (When using USB port everything works fine). The only working solution to connect the drive via eSata is to completely take off the power of the drive (disconnect power cable) then reconnect the power cable and when the drive starts up - immediately connect the eSata cable to the PC (hot plugged). With a chance of 1/5 the drive initialization works and the drive shows up in explorer. If connected in any other fashion the drive gets not initialized / mounted! When the drive shows up in explorer (initialized  / mounted correctly) the drive works fine and fast in eSata mode so I guess the drive is OK and working properly. I thing there is a problem with the controller of the drive so I updated to the newest firmware but that does not help. When the drive shows up in explorer (mounted) every 10 seconds the drive tries to go in sleep mode but starts over. This behavior continues in an endless loop and its noisy and I think its also not good for the longevity of the drive.

If the eSata cable is connected before windows boot up the mount process fails and results in system freezes and strange behavior in explorer: shortly showing up a drive letter but with no access to the drive after a while the driver letter disappears. There is no other way to get the drive mounted then the workaround described above.


#3

Hi Felix, glad to know someone else out there is having the same problem, or similar to mine.  I did not think that the constant activity by the drive is it trying to sleep.  This cannot be good for the drive like you said.

Do you think it is an incompatibility with Intel Matrix Storage Manager?  Can this be disabled?  Do you use raid for your internal drive(s)?

In general it sounds like you are have more connection problems then I am having.  My drive is almost always available but it will sometime disconnect randomly and the only way to fix it is to unplug the drive and plug it back in again.

Have you had any success contacting WD support?  Thanks, Ddeo


#4

Hi ddeo,

I don’t use a raid for my internal drives. The controller works in AHCI mode, 2 drives are connected to it…

As I know you should not disable the Intel Matrix Storage Manger. That is only a software to build raids or to see what drives are connected to the controller. Don’t uninstall it because the needed drivers for the controller comes with  Matrix Storage Manager software! It’s needed for the controller to work properly! Maybe an update to the newest version could help you. You can get it from Intel.

In the past I had Vista 64bit and I had connection problem via eSata too but not that hard ones and not that often.

With Windows 7 64 it’s getting even worse. But the strange thing is that when connected via USB everything works fine so I guess it could be a intel driver problem or it could be an incompatibility between the intel controller and the controller of our external WD My Book Drive. That’s why a made a firmware update of the drive but it doesn’t helped!

I have had contact with Western Digital support because of the firmware is only for windows XP 32bit. I ask for a firmware update which is compatible with win7 64 bit. The answer was not really technical and solved for them because of the missing update.

They told me there is no firmware available for a 64 bit OS… at least I made the firmware update with an old win xp 32 bit system… It was a little bit scary because the firmware update failed 4 times but in the end it worked but changed absolutely nothing of the problem.

At moment I don’t have the time to care about but I will definitely try the support again soon. I bought the drive only for the eSata port!

Maybe you should contact the support and point them here to our postings because I think the controller of the My Book Drive is faulty or broken and maybe a new firmware could fix this.

So good luck to you and thanks

Felix