Install Debian on WD My Cloud home

I extracted wd-myclode-home-debian.7z and all files copied to Flash usb ( fat32 format )
and this flash plug to the device is off,
Press the reset button and power on.the led blink until 20 seconds then led is steady.
then i released the reset button.after 3 mintues the device rebooted but again 3 mintues the device rebooted and again.
i tested http://wdnas but it not found,
I think my problem is formatting flash.do i have to bootable my flash? how? i did with centos iso too with rufus , i didn’t get result.
Please help me .please

The USB Stick must have a size of at least 8GB and an MBR.
Windows automatically creates an MBR while formatting while Linux does not.

I did, after all steps, i can ping to ip address and i see 23 partions created on Hard disk but i cannot access by web or ssh ,

You can try my buster install if you like.

user and password should be in the file (buster/buster). Extract it to OMV directory on your USB stick.
It is the very basic system created following the instructions of Alex-N. No changes.
So you have to add some paths:
nano .bashrc
append in the end:
export PATH=$PATH:/usr/sbin
export PATH=$PATH:/sbin

please help me

Dear @AbuG
I have your primary problem. is there a solution for it?
Please help me step by step.
I’m confued.

@AbuG Yes, you are supposed to create the zip with the file from fox-exe.ru http://fox-exe.ru/WDMyCloud/WDMyCloud-Home/Debian/wd-mycloud-home-debian.7z
Then you copy the three tar.gz files from my archive to the omv folder, overwriting the three files that are there with the same name, leaving everything else untouched.
I put everything in a file which you can extract to a USB stick (>8GB, FAT32 formatted). This will give you the minimal debian buster:
https://c.gmx.net/@328058200588813603/Pk5D2RKaTXawr7RvjnmMUw

So I can use yours without first doing the russian one? As far as I understood AlexN’s method, he too first did the russian method and after that used debootstrap to add a vanilla debian on top. Or am I getting this wrong?

Exactly. If you install the russion one and then follow the Alex-N method, you end up with the file I shared.
But it is not vanilla debian “on top”. It replaces the russian debian/OMV.

@Alex-N I’ve tried installing Buster using the commands from your website, I got the three archives which I’ve moved on the usb (MBR, FAT32 with the russian installation files) overriding the existing ones inside OMV. The installation seems to be fine but after that it keeps rebooting. Any idea?

File info:
20-root.tar.gz 17.993 KB
21-var.tar.gz 1.350 KB
22-usr.tar.gz 51.425 KB

EDIT: solved by replacing this commands
cd /new
tar cfz /srv/dev-sataa24/21-var.tar.gz var/
tar cfz /srv/dev-sataa24/22-usr.tar.gz usr/

Replaced with
cd /new
cd var
tar cfz /srv/dev-sataa24/21-var.tar.gz *
cd …
cd usr
tar cfz /srv/dev-sataa24/22-usr.tar.gz *

@Alex-N If samba is mounted on a server like plex, will it keep the disk awake without letting it go to sleep?

Anyway to get working iptables or ufw?

Wow. This is great work. However, this is a huge thread to navigate. Has anyone written up a howto/wiki guide on how to install this please?

Gents,
I installed Debian buster and kernel compiled with .config from @Alex-N. What I installed:

  1. docker-ce
  2. Portainer
  3. Shinobi
  4. Home-Assistant
  5. Samba on Host
    Everythink working fine but I am trying recompile kernell with AppArmor and Device Mapper modules without any resoult . After I copy it I get bootloop.
    I would like to install HASS.io in docker and Veracrypt in Host that is why I need this modules.
    Maeby someone have proper .config to build kernel with this modules?
1 Like

Hi lukdwo,
When you copy the kernel, do you update the FW_TABLE as described here?

If not, the kernel won’t boot.

Hi juniored,
I done it and finaly I found solution for this issue. I tried HASS.io in Docker but it is consuming with all extensions to much RAM. Can I downsize tmpfs nad how I should do it?

Hi,

I’ve installed OMV to MyCloudHome and it is now super efficient than stock ROM. My question is that is there any way to auto sleep feature like on the WDMyCloud? The HDD always spins, I don’t want it to run when there is no activity within.

Thanks.

Hi xksefa,
Did you get Buster with OMV5 running? How did you do that?

Hi everybody,

I put up a blog to summarise this thread and publish manuals on how to set up your own NFS server, backup an iphone to the MCH or install seafile.

Blog has a German name, but first only in English.

Hi,
Sorry I couldn’t get the question but my OMV version is 4.1.23-1