Install Debian on WD My Cloud home

strange … it works for me without it

Looks like you’re using the systemd-Watchdog feature in
/etc/systemd/system.conf

[Manager]
RuntimeWatchdogSec=45

That works for me as well.

1 Like

That was it. I am using RAH-66 (4.9.266) kernel from the USB Install. Once I set this no more reboots.

Thanks!

WD deleted all versions GPL Monarch? :crazy_face:

I suppose this is just an oversight…
Besides, the new version (8.8.0-112) didn’t change anything in the kernel.

In case anybody is still interested - I did actually try a return to the factory image.
(I have a couple of these devices. I am still running Debian Bullseye on 4.9.266 on my production unit :wink: )

I left the GoldenImage partition untouched, that’s why this worked:

mount /dev/sataa18 /mnt/
echo '5:F:2:;' > /mnt/bootConfig
umount /mnt
reboot

The unit updated itself to 7.16.0 within minutes. I am now waiting for 8.x.y to have a look at everything else.

After upgrading to version 8.xx, please look at the partition table on the HDD for differences.

New USB install works great! Using for a week now, no issues.

Agree, WD removed the Monarch firmware, wonder why?

Hi,

is this a problem:

Aug 6 11:24:20 MyCloudHome collectd[3617]: rrdcached plugin: rrdc_update (/var/lib/rrdcached/db/localhost/rrdcached/counter-journal-rotates.rrd, [1659785060.727909:0], 1) failed: rrdcached
@unix:/run/rrdcached.sock: illegal attempt to update using time 1659785060.727909 when last update time is 1659785511.000000 (minimum one second step) (status=-1)

or can i ignore it. I found it on /var/log/daemon.log

interesting:

My Cloud

Meet ibi, the smart photo manager – collect, organize and privately share

Speaking of wireless, trying to get a USB RTL8188C working. When I run make for the driver I get header errors.

apt-get install linux-headers-$(uname -r)
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
E: Unable to locate package linux-headers-4.9.266
E: Couldn’t find any package by glob ‘linux-headers-4.9.266’
E: Couldn’t find any package by regex ‘linux-headers-4.9.266’

Anyone know what snapshot archive to add to snapshot.list ?

I had to compile the kernel and run
“make headers_install INSTALL_HDR_PATH=/usr/src/linux-headers-4.9.266”
to get the headers installed.

apt search linux-headers-

Hi @zeusjan i try to install the Deb10+OMV5 with the USB Images on my MCHD. It works until the system reboots after the successful installation in golden image boot. It reboots in recovery mode, using the usb boot.

[INFO]: bootState: BOOT_STATE_NO_OTA
[FATAL ERROR] CBR not found, boot USB rescue mode.
==== boot_rescue_from_usb =====
(Re)start USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 1 USB Device(s) found
USB1:   USB XHCI 1.10
scanning bus 1 for devices... Unknown request , typeReq = 0x200c 
2 USB Device(s) found
USB2:   USB XHCI 1.10
scanning bus 2 for devices... Unknown request , typeReq = 0x200c 
1 USB Device(s) found
USB3:   USB XHCI 1.10
scanning bus 3 for devices... Unknown request , typeReq = 0x200c 
1 USB Device(s) found
       scanning usb for storage devices... Enter is_pmbr_valid
Warning: failed to 0xEE type in MBR
1 Storage Device(s) found

I try to fix that … but nothing change :frowning:q

need USB with MBR or replace a USB if has corrupted

Hello, you don´t have any need to touch the golden sections, you only need to modified the A or B sections (depending on where you gonna boot), but for the look of that log i believe that you mess more than the golden section, it looks like you delete or modified the FW Table, and that´s why your NAS is trying to boot from the usb, a normal boot with a functional FW table should look like this:

[INFO]: bootState: BOOT_STATE_NO_OTA
Start Boot Setup ...
---------------LOAD NORMAL FW TABLE ---------------
[INFO] fw desc table base: 0x00620000, count: 13

If you have a backup, i recommend you to load the backup and start from scratch, if you don´t have any, I can share a fw table with you, but i can´t guarantee is gonna work

Ok, i’ll try to restore the FW-Table. I guess it is possible with the uboot toolset right? Simular to this tutorial: RTD129X Unbrick

Otherwise i can try to fix it with your shared table too.

Thanks in advanced!

Edit: I try to fix the FWTable but without success…

REBOOT_ACTION : No Action
Hit Esc or Tab key to enter console mode or rescue linux:  0 
------------can't find tmp/factory/recovery
======== Checking into android recovery ====

reading bootConfig
Filesize: 8 bytes
8 bytes
Size: 8, got: 8

8 bytes read (take 6ms)

[INFO]: Boot golden image
Start Boot Setup ... 
---------------LOAD  GOLD  FW  TABLE ---------------
[INFO] fw desc table base: 0x00628000, count: 13
Normal boot fw follow...
GOLD Kernel:
         FW Image to 0x03000000, size=0x00c44e00 (0x03c44e00)
         FW Image fr 0x00a70000 
GOLD Rescue DT:
         FW Image to 0x01f00000, size=0x0000ef5a (0x01f0ef5a)
         FW Image fr 0x00630000 
GOLD Rescue ROOTFS:
         FW Image to 0x02200000, size=0x00c00000 (0x02e00000)
         FW Image fr 0x01a70000 
         FW Image checksum FAILED
         FW Image entry  checksum=0x3fff93a7
         FW Image result checksum=0x3fff9630
Booting golden image, use default bootarg

It shows “FW Image checksum FAILED” and boots again in USB Discovery :frowning:

this is 4.1 though, what is the link to the latest kernel?

I don’t know exactly how the bit sequence in the MCHD works… this is from the uboot source:

static int wd_boot_cbr(void)
{
	char *cbr = NULL;
	cbr = getenv("cbr");
	if(cbr != NULL)	{
		if( strncmp(cbr, "A", 1 ) == 0 ){
		// set the boot_mode
			boot_mode = BOOT_NORMAL_MODE;		// A image
		} else if( strncmp(cbr, "B", 1 ) == 0 )	{
			boot_mode = BOOT_RESCUE_MODE;		// B image
		}else {
			printf("[FATAL ERROR] Invalid CBR(%s) from uboot env, boot USB rescue mode.", cbr);
			gUSB_MODE = 1;
			return -1;
		}
	}else {	//unknown cbr
		printf("[FATAL ERROR] CBR not found, boot USB rescue mode.\n");
		gUSB_MODE = 1;
		return -1;
	}

	return 0;
}

Maybe it’s just as easy as writing the correct string to the config partition

mount /dev/sataa18 /mnt/
echo "2:B:2;" > /mnt/bootConfig

Sorry, I replied while you edited your post :slight_smile:

What are the two lines after the FW Image checksum FAILED?

Maybe you can fix this by using fwtablectl

It looks like you managed to fix the golden fw table, i believe that you had a checksum error because you change the kernel, dtb and rootfs on the beginning . What method do you use to change the kernel, rootfs and dtb file when you installed Debian? you used fwtutil from forth32 or other method???. you need to write again the kernel, rootfs and dtb file with a utility that modified the checksum on the fwtable (like fwtutil from forth32 install image). And you need to check and double check that you are going to write every thing in their corresponding place (the kernel on the golden kernel, etc.). the best practice now that you recovered the golden fwtable, is copy that table over another partition (1 or 2) and try to boot from there to no mess anymore with with the golden boot, so you can recover if you had any problem.