Install Debian on WD My Cloud home

This installation flash drive is only for the version of WD MCH (Monarch/1HDD), probably the separation GPL from the DUO went deeper

overlooked …

fixed errors on the installation flash drive in makepartshdd.sh and etc/network/interfases

redownload install drive

guide

in system now ver.kernels 4.1.17 and 4.9.266, for change ver. command:

/boot/bootA                                   #ver.4.9.266 +GPU (RAM ~750MB)      
/boot/bootB                                   #ver.4.9.266 -GPU (RAM ~1GB)
/boot/bootG                                   #ver.4.1.17  -GPU (RAM ~1GB)

boot branch A
boot branch B (Rescue)
boot branch G/Gold (“Factory”)

All kernels boot one system.

Getting closer. It creates partitions and does pickup an IP address. :grinning:

Issues
The watchdog timer is active and rebooting every 2 minutes.
I have console access for Root but can’t connect to the IP address with ssh.

Thanks for all the work!

Regarding some of the left over memory. I decreased the ION_MEDIA_HEAP_SIZE2 from 60MB to 16MB. (trying 12MB still gave an error):

/* legacy : 60 M */
#define ION_MEDIA_HEAP_PHYS2 (MEM_SLOT(2, PHYS, 0x01000000))
#define ION_MEDIA_HEAP_SIZE2 (MEM_SLOT(2, SIZE, 0x01000000))
#define ION_MEDIA_HEAP_FLAG2 (MEM_SLOT(2, FLAG, 0x01000000))

@JohnsonEW regarding the watchdog; you have to use /dev/watchdog now. I use the Debian provided watchdog package, please see my config above.

1 Like

boot from usb, mount sda19 and edit /etc/ssh/sshd_config:
“PermitRootLogin prohibit-password” → “PermitRootLogin yes”
or
sed -i ‘s/PermitRootLogin\ prohibit-password/PermitRootLogin\ yes/g’ [Path]/etc/ssh/sshd_config

I fixed the errors, try downloading again and installing clean (link in the post above)

Yes, I downloaded the new zip and it works well. I haven’t installed OMV, have to figure out the disabling watchdog Alex-N posted info on.

and where is it?

I enabled this setting:
cat /etc/default/watchdog

Setting the boot mode to 5 in the bootConfig should trigger the BOOT_GOLD_MODE
(bootloader/uboot/common/cmd_boot.c)

1 Like

sorry originally it reads

/* legacy : 146 M */

(same file you used)

1 Like

I can’t figure out how to stop the watchdog / reboot with the 4.9.266 kernel. If it’s compiled in the kernel is it possible to disable it through settings / software? The Debian watchdog software package doesn’t have an effect on the reboot.

The 4.1.17 kernel works great - no issues.

This is how I have it running (I forgot to mention the config of the watchdog service)

/etc/watchdog.conf

watchdog-device         = /dev/watchdog

/etc/default/watchdog

# Start watchdog at boot time? 0 or 1
run_watchdog=1
# Start wd_keepalive after stopping watchdog? 0 or 1
run_wd_keepalive=0
# Load module before starting watchdog
watchdog_module="rtk-wdt"

The last line is optional if kernel doesn’t use modules.

strange … it works for me without it

Looks like you’re using the systemd-Watchdog feature in
/etc/systemd/system.conf

[Manager]
RuntimeWatchdogSec=45

That works for me as well.

1 Like

That was it. I am using RAH-66 (4.9.266) kernel from the USB Install. Once I set this no more reboots.

Thanks!

WD deleted all versions GPL Monarch? :crazy_face:

I suppose this is just an oversight…
Besides, the new version (8.8.0-112) didn’t change anything in the kernel.

In case anybody is still interested - I did actually try a return to the factory image.
(I have a couple of these devices. I am still running Debian Bullseye on 4.9.266 on my production unit :wink: )

I left the GoldenImage partition untouched, that’s why this worked:

mount /dev/sataa18 /mnt/
echo '5:F:2:;' > /mnt/bootConfig
umount /mnt
reboot

The unit updated itself to 7.16.0 within minutes. I am now waiting for 8.x.y to have a look at everything else.

After upgrading to version 8.xx, please look at the partition table on the HDD for differences.

New USB install works great! Using for a week now, no issues.

Agree, WD removed the Monarch firmware, wonder why?

Hi,

is this a problem:

Aug 6 11:24:20 MyCloudHome collectd[3617]: rrdcached plugin: rrdc_update (/var/lib/rrdcached/db/localhost/rrdcached/counter-journal-rotates.rrd, [1659785060.727909:0], 1) failed: rrdcached
@unix:/run/rrdcached.sock: illegal attempt to update using time 1659785060.727909 when last update time is 1659785511.000000 (minimum one second step) (status=-1)

or can i ignore it. I found it on /var/log/daemon.log