Impossible Experience trying to connect MyCloud to a different computer on the same network

You appear to be looking in the wrong place in Windows File Explorer. You need to look under Network and select the correct My Cloud icon there (see red boxes below with arrows).

I have been clicking Network for about 6 weeks now and all that I am able to see as of my interaction with you is what follows.

Right, and what happens when you open the My Cloud icon you have highlighted in that screen capture? Does it change to show the My Cloud Shares on the right side? Like in the example below?

To make things easier one can (if they can access their My Cloud on the local network), “map” Shares to their computer for easier access.

I couldn’t continue yesterday. I was told I can only do so in 21 hours

Couple of things to check. Is the Network Type set to Private?

If you have any security/firewall software installed, check that software to ensure it is allowing access to the local network.

Try accessing (if you haven’t done so already) the My Cloud by it’s IP address. For example in Windows File Explorer address bar: \\ (use your My Cloud IP address)

This is what I get when I plug the old computer to the network. The drive works perfectly.Network2

OK so the old computer doesn’t have a problem. Obviously that means the newer computer itself is the problem.

Are you running any security or anti virus software on the new computer? Some have been known to block or cause issues with accessing local network devices.

Hello Bennor:

Thanks for the response. The only anti-virus software installed is Windows Defender. I have looked carefully at that but cannot see what may be blocking it.


When you get the window that says can not access. Did you try to click diagnose button and see why it is failing?

Also check Windows Firewall if you are not using a third party firearm program and see if somehow it’s blocking access some how.

Not sure if it would help but perhaps rebuilding or resetting the network stack to default might solve the problem.

I have been trying to diagnose the problem. Here is the result.

I also reset the Windows TCP/IP stack. Made no difference.

Have you tried accessing the My Cloud by it’s IP address? Both in a web browser and in Windows File Explorer?

I have tried unsuccessfully to access the drive in a web browser and with File Explorer

When the computer boots up I get these notifications…

  1. Firmware Update Failed

  2. Firmware Update Successful

  3. WDMYCloud - Ethernet Port %1 Connected at 10/100

  4. Power loss detected

5.Network Link Down

6.Network Link Down

  1. Network Link Down

8.Downloading Firmware Update

  1. Installing Firmware Update

Sounds like the firmware update failed and the My Cloud is stuck. May want to contact WD Support directly (if you haven’t done so already) to see what they suggest.

If you had SSH enabled see if you can still access the My Cloud using SSH. At leas then you have some access to the device to try and figure out what is happening by using Linux commands.

Another option is to remove the My Cloud hard drive from it’s enclosure (will void the warrenty) and try pushing the firmware to the drive via one of the unbrick methods. There has been discussion elsewhere about pushing just the IMG files to the one or two partitions (depending on My Cloud firmware version) to try and fix a hung firmware update.

Not sure if it’s possible on the second gen v2.x My Cloud’s since they use a different Linux structure, but if one has a first gen v4.x My Cloud they can use SSH to trigger a firmware update from a manual file download. See the following post for more information.

That appears a bit too complicated for my pay grade. I have contacted Support and waiting to see what they can do for me.

It appears that the problem is not with the drive but with the computer. Someone from the company struggled with it for about 30 mns, couldn’t find the problem and suggested I contact Microsoft.