I'm out of options with mycloud and smartware

#1

Hello everyone.

I’m running windows 10 (tried before updating to anniversary edition and after).

The mycloud device is always online, so connectivity is not an issue. Transfers are blazing fast, that’s not an issue either.

However the problem comes with smartware more than anything else. I don’t know what causes it at all, but in network the mycloud device appears both as storage and media (because of the twonky server). Everything’s alright, right? Not quite.

After a few minutes, they both disappear into oblivion, but what puzzles me the most is the following.

WD sync still knows the network drive is there
WD access still knows the network drive is there

Smartware is like: “huh? I’m just gonna cut your backup and remove it as target because reasons”.

It seems like devices connected through wi-fi do not have this problem, and I believe the culprit is the driver that auto-installs the NAS device. No matter how many times i try to remove it entirely, I can’t seem to find a way to avoid the auto-configuration of the device. You know, when it shows a generic NAS icon, like it does on the wi-fi laptop, it keeps the connection up. When it’s connected through ethernet, it displays an icon that looks like the MyCloud device, then drops it after a few minutes.

Everything else works perfectly.

I tried literally everything, ranging from turning on features and services to factory resetting the MyCloud device. Everything’s updated to both latest firmware and version of the programs.

I am lost, completely. If there’s a way to avoid the auto-install of the device under Western Digital NAS, i’d like to give it a try.

#2

Does your My Cloud have a static IP address? If not assign one either by reserving the IP Address within the router’s DHCP server or assign a fixed IP address through the My Cloud Dashboard > Settings > Network section.

Windows 10 is sometimes quirky with the My Cloud and its more an issue with Windows 10 than the My Cloud. You may want to dig through the following thread to see if anything might solve your issues.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

1 Like
#3

Tried every method on that thread. Also running on static IP.

As I mentioned, it never loses connection through wi-fi, but with ethernet connected devices, it does. Both computers are running win10 too.

I know it might be a windows 10 issue, but I haven’t found the reason.

Let me clarify further:

Anytime I disable and enable the ethernet connection again on the PC, it shows up again. 5 minutes later (typically it’s around that time) it disappears into oblivion, causing smartware to cease doing a backup. Every other WD application seems to still be able to pick it up. All the network folders still work.

It’s just that smartware can’t function properly if the network storage icon disappears, from the looks of it.

#4

Try turning OFF UPnP.

Paul

1 Like
#5

I turned off UPnP and on later. I also disabled the DLNA media streaming service

Aaaand it works now.

PS: Since I don’t want to break the backup, i’ll test later which one was the culprit and mention it here