I'm having a problem with my portable hard drive. WDBAAA2500ASL model. (Help, I'm a computer noob)

http://www.newegg.com/Product/Product.aspx?Item=N82E16822136807 So I bought this on February and it worked like a charm… until 2 weeks ago where it stop showing up on my computer and working for my computer and other devices. So I go to Computer Management and see this… http://i.imgur.com/bipxh.jpg Disk 1, that’s my portable hard drive. But instead of being 250 GB it has some weird number (honestly I have no idea where that 2TB bit came from) and it’s unreadable, unknown and unallocated. I can’t format it, I tried numerous downloads to try and fix this and at this point I don’t know what to do. ._. Please help me (at this point I couldn’t care less about the data on the drive, I just want a good hard drive.)

When you tried to format it did you delete the partition/volume first?


I don’t think so.

Dude, you’ll have to replace it. ANY drive that shows a much larger capacity while unallocated means the drive had a physical failure with the platters, and has no fix.

If you’re out of directly warranty with Newegg then call WD since that drive should be under warranty.

Oh, thanks. **bleep** I can’t fix the little guy. :frowning: