Icons/Movie Covers WDTV Live Synology DS106/DS410J


#1

I have a small issue to do with ICONS (Movie Cover) of movies and my WDTV Live. Now I am not saying it’s the fault of the anyone devices, but they are reacting differently when it comes down to this.

Okay the

DS106 is UPnP enabled.
DS410j is UPnP/DLNA enabled.

In the folder in question, the following files are in there.

folder.jpg
movie name.jpg
wd_tv.jpg
movie.mkv

DS106 via the network share option of the WDTV Live, I see one icon representing the movie and when I click on it, the movie plays. I don’t see anything else. Excellent :slight_smile:
With the DS410J when I go into the same folder see I four icons.

folder.jpg
movie name.jpg
wd_tv.jpg
movie.mkv (But with the image of the movie representing it e.g. movie name.jpg)

What I am trying to fathom, is whether the DS106 is presenting the data correctly, or the DS410j via the network share connection.

Now to throw something further into the mix. If I use the media streamer option on the WDTV Live and navigate down to the folder in question, I merely see a generic icon and not even a movie cover. The mkv plays fine, but it lacks that movie jukebox feel I am looking for.

I am try to work out what I need to do to have movie covers via all views.

Now when I was originally working out what jpgs I needed I was using the DS106 as my test bed. So the folder.jpg handled the folder views within the WDTV Live and the movie name.jpg handled the ALL Video view. This even worked over the network share. So movie covers all round, so I was happy.

When I added the DS410J into the mix, which has DLNA support, it didn’t quite work out as well. To be honest I am looking for guidance.

I would be very disappointed if the WDTV Live needs lots of different icons for each view.

Any thoughts would be appreciated.


#2

I am also struggling with this issue, although to me it is a rather important one since I want the entire family to be able to use the device intuitively.

I also have a Media Server (although it’s a WD MyBook World Edition II running TwonkyVision 5.1). The disks on the MyBook are also accessible as Network Shares.

Accessing the movies from the Media Server renders the same result as you Skarr, i.e. no nice pictures, only some default and rather dull Icons.

However, the problem does not stop there, since I am actually not able to watch any video whatsoever using the Server option. My WD TV Live reports Not a supported file format for each and every movie (i have avi, mpeg, ts and some Vobs).

What might I be doing wrong?

The Thumbnail issue is rather tricky it seems, at least I am not really able to get to grips with it. At the moment I have a directory containing a few different Folders for some different Movie Genres. Each of those directories have a folder for each movie containing:

Movie.avi

folder.jpg

I have understood now that I probably should have a file named movie_name.jpg as well.

When I select a directory containing my movie folders I get a very nice view with 2 rows of 6 DVD-pictures, and the option to step down to see more… So far so good but when I want to watch I movie I had expeted to be able to select one of the shown pictures and Press Play. However the WD TV Live then “plays” the folder.jpg file. So in order to view the movie I need to enter the folder and select the movie file, which is shown as a default Icon only (possibly solved by adding the file movie_name.jpg), next to the picture contained in the folder.jpg.

In your example Skarr, you also have a file called wd_tv.jpg, what is the purpose of this file??

I have seen somewhere that someone said the picture files should not have the extension name (jpg), also that there should be no spaces in the names. What files are really required and how do they “work”??

Is it even possible to get it to work in the way I am expecting, i.e. not being required to “enter” the folder but rather just select a file and click Play…


#3

I’ve got similar issues.

I don’t think it’s relevant but I’ve got the WD TV Live hooked up by cable thru a DSL-604T to my PC (USB Wireless logon was just too unreliable despite being only 3metres away thru one light internal wall with excellant signal strength and a a good conenction once logged on).

Anyway…

Despite following the naming scheme for thumbs and jpgs etc, I don’t get nothing like what I expected or wanted.

I’ve followed the tips from this website but I don’t see anythumbs, let alone any clever “cover flow” for anything anywhere.

I get thumbs on folders in the Network share view but then I can see the individual jpg files and a generic thumb for the video file when I look inside the movie’s folder.

I don’t get customised thumbs of any kind (just generic) when I browse thru the media server option.

Like you, I want other family members to use it easily and thumbs would help me to acheive that - and I don’t get thumbs.


#4

i’m having the same issue, it appears.

when i attach a USB drive to my WDTV LIVE, and select local drives, then ALL VIDEO, i don’t see the folder.jpg image, i see a generic image, but…if i select FOLDERS, then i see the movie cover (labeled folder.jpg) and when i select that, it takes me to the movie file which i select and it plays.

i want to be able to have the DVD COVER show up when i select ALL VIDEOS, click on the picture and have the movie start.

anyone know how to do this?  it must be possible, but take it easy on me, i’m new to the WDTV LIVE system


#5

Thumbnails are  a well known issue. Check  this and other forums for multiple posts. We have to await a hopeful fix in the future.


#6

so i got all my thumbnails to show up on the folder and the .mkv file.  

tomorrow i’ll try to get rid of the .jpg and see if they still show up.  i believe, now that they are attached, i can remove the extension on the jpg and/or delete the file entirely and it will still show up.  i tried it with one and it worked both ways.

this is what i did.  resized pics to be under 70kb, folder, jpg and .mkv all exactly the same name with not spaces, i used a “.” where there would be a space.  they still didn’t show up after i did all that, so i powered it off, then unplugged it to reset the cache.

i am hoping everytime i want to add a new folder or image, i don’t have to unplug this thing, that will get really annoying.  and if i do unplug it and i have already removed the .jpg image from each folder that those ones don’t disappear

i’m also wondering if instead of folders for each movie, if i just have one folder called DVD and/or one called x264 that i can just put the movie folder in there with a .jpg named the same, have them merge, then delete the .jpg and have a just the movie file in there with the image as it’s thumbnail, we’ll see about that though.


#7

update…

looks like there CAN be spaces in the folder name, title and jpg as long as they are identical in all.

it works with mine with the spaces as long as they are all IDENTICAL and the image is under 70kb.

now i’m trying to get it to work so the .jpg doesn’t show up in the folder (i just want to see the video file with the image on it), but i’m not having any luck.  

i’ve tried removing the extension but it doesn’t show up on the .mkv file, it does show up on the folder though.  i’ve tried removing the .jpg entirely, same result.

i was also under the impression (or at least someone else had said) that if you hit PLAY on the VIDEO FOLDER that contains the .mkv and .jpg, that the movie would play from there, there was no need to go into the folder and select the video image and select it.  but when i hit PLAY on the video folder, the .jpg image is displayed full screen

i’m guessing this is a BUG or FEATURE as the call it.