I want my data back! (WD20EARS 2TB)


I think I’m not the only one having this problem. I just wanted to inform you that I lost almost 1 TB data within 1 1/2 month using the HDD (WD 20 EARS Eco Green). Don’t buy it unless you want to have a big data grave.

This was my last WD drive. Thank you very much WD!

And that’s why you should always have a backup of your data…

Are you sure it can’t be recovered? What you try TestDisk or even Ontrack software?

no chance since it’s not recognized by the bios nor windows nor osx … so no chance unfortunately…

I have the same issue! It worked for a month or so, and then all of sudden nothing shows. Tried in Win7, XP, WDMedia Player. Tried different cables  using SATA, esata, Docking station, sata to USB with no luck. Bios utility shows it as a 0MB drive. But nothing is visible through disk management or during bootup. Device Manager does show USB device on using a sata to usb cable, and allows option for ‘safe removal’ of mass storage but no access to storage.

If anyone know how to get to the data please let us know.

i think im lucky ( KNOCK ON HOOD)

i have already backed up the most important data but because its a 2TB drive i cant backup all the data… only the most important

my drive has been rock solid for almost a year now (10 months) it has been working on  external enclusure but now its internal and working on my destop pc that i use everyday basis

the old version with 4 platters wd20ears…

lets see how that goes… hope that mine will survive … its very bad sosing data because the drive doesnt show… at least should gives us some sgn of failure for us to get another hard drive in time

im waiting for new technology… 2 platters like samsung showed ( and with that lower prices) for backing up the rest

Has somebody tried to repair this? I have some other WD 20 EARS drives - I guess it’s not as easy as just changing the outer board, is it? So … would need to replace the heads where I guess I could break more than fixing the drive…