I think that topic WD World Edition white light freezes/locks up isn't solved

Hi, community!

Topic WD World Edition white light freezes/lo​cks up up was closed, but I found new data for this problem.

I tried to contact to WDC support, but they don’t want to contact((

MBWE freezes again and again (NFS, SSH, Web-iface, Twonky isn’t accessible; pings are fine).

I saw log’s of MBWE and found a strange thing. In system logs there are no abnormal messages. But in CIFS there are next strings:

2011/09/24 10:09:21 780ee3fd8e50418 ( closed connection to service Public
2011/09/24 09:53:21 Error writing 4 bytes to client. -1. (Connection reset by peer)
2011/09/24 09:53:21 write_data: write failure in writing to client Error Connection reset by peer

I found, that error is repeating every time before MBWE freezes.

Any ideas about this strange “Error writing 4 bytes”?..

P.S.: I use SSH, Twonky server, NFS; UPnP is enabled. iTunes, AFP, MioNet, FTP are switched off. Firmware was 01.00.16, then was updated to latest 01.02.10.

V  01.02.10. is bug ridden and falls over continually, we are all currently waiting for WD to release a fix, which should now be this week

I think you need to re-issue /re-state your problem once the fix has gone in for  01.02.10.

Hi  community,

i also think the   WD World Edition white light freezes/lo​cks up topic solution is not the definitive solution :

I had a few time ago a similar issue with my mybook Whitelight, and firmware below 1.02.10, and i identified that some specific files was corrupted and each time i was trying to read them, the Mybook was freezing. The only solution was then to reboot the mybook and start again…

==> Mionet has a scan feature that scan regularly the files, each time Mionet hits the faulty file, the mybook freeze… This explains why disabling mionet did work for some users.

1)  if the issue is a recent issue, and you have a few time before the mybook freeze, think about recent files you have uploaded, or files that you may have been uploading , but a power outage just cut the upload. Then try to copy the suspected files out of the drive. if you can identify that each time you try to copy this file, the mybook Fails, simply delete the faulty file.

  1. if you cannot identify the faulty file, you can also plan to copy all your files out of the box to a new drive, then when all your files are safe in a second drive, you can delete all the files on the Mybook. When the mybook is blank with no files , you can then perform a reset to factory settings ( which usually deletes everything). then, you can copy all your saved data to the newly formated mybook.

  2. if youdo not have any spare disk and you are not afraid to mess all your data , i have read a post on the wikidot forum which could solve the issue :  ( these commands will try to repair the xfs file system, but if there is another problem on the mybook, such command could simply delete all your files ! ) I strongly recommend that you make a backup of your files before you try this command :

a. discinnect all drivers and stop all process that accesses the Datavolume partition :

disconect all computers from the Mybook.

b. cd /shares

c. ls

d. umount every listed directory  ( umount foldername)

e. Umount /DataVolume

f. Create a 300 MB file for extra swap (trust me, you’ll need it), make it usable and activate it:

   dd if=/dev/zero of=/root/extra.swap bs=1M count=300
   mkswap /root/extra.swap
   swapon /root/extra.swap

g. check that  ls /DataVolume  does not list any file

  1. Run a 1st-pass, no writing, check of your xfs volume:

   xfs_repair -n /dev/md2

  1. If you feel comfortable with the sample output, run it:

  xfs_repair /dev/md2

  1. After the check, stop you mbwe with the # halt command, power it off, give some seconds and re-power it on

Good luck. Greetings from sunny Brazil.

NOTE : regarding latest firmware 1.02.10 , i have not been able to reproduce yet the freezing issues that some users are highlighting. May be these users also have the corrupted File system bug?

Hoping this will help…


rejector &  teinturman, the thread was marked as solved by the very owner of the original thread as that post seemed to solve the author’s issue and as an appreciation token, the post was marked as the solution.

It is currently closed due to its age as well as most threads with no new replies during a set time frame.