I regained access to my external hard drive!

Saludos Amigos,

(Greetings Friends,)

I ran a clean install of Windows 7 on my computer (it had a virus).  After doing that, I tried plugging in my 2TB My Book Essential to reload all my old pics, music, & other things…

Unfortunately, I kept encountering a message of “USB Mass Storage Device not supported”; and later, “Access is Denied.”  I was scared everything would be inaccessible and erased!



If you’re having a problem getting your external hard drive recognized, make sure “Everyone” has “Full Control” access to the drive.

Open “My Computer”, right click and pick “Properties” in the context menu. Then select the “Security” tab. Once that is up, click the “Add” button, enter “Everyone” in the field provided, hit “Apply” then “OK”.


I can see all my backed up files now!

PLEASE SPREAD THE WORD!!!  I spent hours looking for information on the WD forums and in other places, but nothing seemed to work…UNTIL NOW!


Hi there.

Yep that works… With most drives and folders.

W7 is very strict with drive permissions and user folders, so W7 can block access to your files if it thinks that you’re not the original owner, even if you are…

I had permission problems when I upgraded Windows 7 to SP1. It’s also not always simple to enable permissions in there ether! Almost as bad as networking.