I/o error


#1

i recently knocked my “my book essential” external hard drive over. after spending most of last night trying to access the drive, i shut it down. this morning i started it up and i got access to the drive but i can’t access any of the files. every time it try i get an “i/o error.”

is there a way to get to my info or is it a total lost?


#2

I am experiencing the same problem after the drive being accidently turned off and have similarly spent much of last night and today trying to fix it. Mine won’t even show up in my computer-in fact when i try to get ‘my computer’ it just freezes.

I have shut down, replugged my book into different usb, rebooted but nothing!

Hope someone can help us soon!!!


#3

hi,

i can help. seem your drive has been damaged. may be it got firmware problem or crash head. 


#4

Thank you i will try it tonight!


#5

My WD My Book has the same problem, is there any update of fixing?


#6

OK, I’m getting an I/O error on my WD 250 External Hard drive. It was working fine last night. Shut down my laptop and today it spins and spins and ultimately I get a “Device I/O error”. Please help me recover…MY WORLD is on that external hard drive.

Additional info: running bootcamp Vista partition on MacBook Pro. Tried it on the MAC OS; it never showed up on the desktop. On another PC same problem. Tried it on a Unix box that it worked on yesterday and it won’t read it either.


#7

Same problem here with My Book Premium 500GB. I can see it on my device manager. Sometimes I see the files on it, but I can’t copy to it. Running Windows Vista.


#8

Me too! Googling suggests that I/O errors are a very common problem with WD pocket drives! My 320 Gb “My Passport” pocket drive (< 2years old) gives the following I/O error when I try to delete certain folders and files on it:: “The request cannot be perfromed because of an I/O error.” I also tried to format it through DOS and Windows. DOS required me to force a dismount because DOS thought the drive was in use by another user. Windows format just did nothing for 3 hours (but the light flashed). Is there any way to reformat it? I have tried Windows Check Disk with “fix” options ticked, but it runs all day and does “nothing” (i.e. shows now progress on the progress bar). My old 60Gb Anypak drive ( www.anypak.co.uk/) has lasted 10+ years and was light (and able to be used will moving). I have taken much greater care with my WD Passport drive because the instructions said not to move it while attached to the PC. These I/O errors started when I bought another WD Pocket drive and had both connected at the same time (not sure if this is just a coincidence). I am disappointed that it is virtually unsuable within 2 years of purchase. Is there a utility I can use to remove the I/O error or reformat the drive please? Thanks in anticipation of your help! Jezza11