I NEED HELP, I can not select WD My Cloud as a Backup Target

I am a little frustrated here as for several days now I have been attempting to use my new wd My Cloud 3tb as a means for continous backup - HOWEVER - I am unable to select my My Cloud as t backup target - instead all I see is an option for dropbox. 

Can anyone please advise me as to what I need to do?

Other than the obvious below:  (which does not work)

Selecting the target device to back up to

If you have more than one backup target device connected to your computer, then you must select the one that you want to back up files to before beginning a backup.

  1. Click the Home tab.
  2. In the Backup Target area of the Home screen, click the icon of the backup target device that you want to backup files to.
  3. Verify that a light-blue background highlights the selected device.
  4. If the selected backup target device has more than one drive partition or network share, use the backup target selector box specify the one that you want to use.

Getting more and more frustrated with this machine that I thought would be a handy tool -

sure would be nice if it worked.

How is your My Cloud connected? Are you on a laptop or desktop, image says laptop? Did you give the laptop cloud access or did you use the laptop during the setup process?

I am connected via laptop

I would like to think I gave the laptop cloud access - I can access files that I manually back up - however it is the contentious back up that I am truly attempting to configure.

Did I use my laptop during the setup process?  Yes I did.

Once installed I was able to locate the WDMYCLOUD within my network.

I can open the folder and copy paste respectively.

However I am not able to use the smartware to designate a target backup

Click on Start>Devices and Printers and see if you can see your My Cloud. If you can, right click on it and click troubleshoot. See what that says.


Can you still see it in your network?

I have the same problem on my Windows 7 Enterprise machine. I emailed support, and they suggested it could be my firewall/antivirus software. This is my work laptop, so I can’t change settings there unfortunately. But if you have the option, see if you can allow traffic from the Smartware app through your firewall.

Also, try mapping a drive letter to the backup share.

Not sure if this matters but also check to see if Network Discovery is turned on in Network and Sharing Center.

hellghoti wrote:

This is my work laptop

Eeeek!   My IT Security folks would be all over anyone who was backing up their work laptop on personally owned media.  :dizzy_face:  :smiley:

Had the same problem and have been trying to fix since I bout the My Could 3 days ago and I just found the magic fix. :smiley:

I am running Win7

go to control panel then networks and sharing center

Left panel go to advanced sharing settings.

Under home or work

Turn ON network discovery

Once that’s “ON” mine showed up right away.

What that does is turn on the UPnP in windows, in my case it was shut off. I did have trouble getting it to turn on. It kept going back to off and wouldn’t stay on. Finally found a small program that worked to change it permanently

If you have the same problem as me getting it to stay on I went to grc.com and searched UPnP and found a program that turuns it off and also on,

I don’t want to take any credit away from Brkdnc, just want to add this image and remind everyone after making changes be sure to Save Changes at the bottom. That should make the changes stick.

Thanks for the Picture, I did the save changes at least 5 times but for some reason it didn’t stick. That is why I had to use that little program. I guess next is to figure out why the save changes didn’t work.

I was having the same problem. I was able to turn on Network Discovery by doing this:

start/run  type “services.msc”

SSDP Discovery Service… Automatic… Started

Universal Plug and Play Device Host… Automatic… Started

Once that was done, WD My Cloud appears in Smartware as a backup target. Hooray!

But now I’m having another problem, and I wonder if anyone here has advice - it requires me to login every time. I have it set to back up to a private share. I read in another thread that unless I set  the share to public I won’t be able to back up wihtout entering the login every time. Is this ture? If so, it’s not very secure.