I do not see my shared drives!


#1

I just bought a WD Live TV and I cannot connect it to my network shared drives. It Don’t see nothing at all and I do not see the WD Live on the network either.

Connected wired, I have a DSL “Neuf box” and a Linksys 54 GS Wireless router, and Ethernet switches … The router IP (Gateway) is 192.168.100.100, and the Neuf Box is 192.168.1.1 acting as DNS. My PC and the other stations got addresses from 192 168 100 to 101 192 168 100 199 without any problem (including BTW a blu-ray player LG BD-570 which worked fine and sees immediately all the shared drives …)

In Auto mode the WD Live can connect to the Internet (I have Youtube etc …) but impossible to know what IP address it got ! He said 192.168.1.32, gateway and DNS to 192.168.1.1, which is obviously wrong! The worst is that when I try to switch to Manual by assigning an address between 192 168 100 101 tp 192 168 100 199 and ti replied: “bad IP address, please try again”:

Pleas help !


#2

Your addressing configuration is definately ODD, if not entirely wrong.

The 192 networks are what’s called a Class C address space.

Class C’s are noted by the first THREE NUMBERS by default.

So in your case, 192.168.100.x and 192.168.1.x are completely different networks.

The only way you can have 192.168.100.x and 192.168.1.x in the SAME network is if you use a Subnet Mask of 255.255.0.0, which is VERY unusual for a Class C.

The only other way that would PROPERLY work is if there’s a full-fledged ROUTER between the 192.168.1.x and 192.168.100.x networks.

If they’re actually on the SAME network, then what you’re trying to do is called “Super-Netting.”   I don’t understand why you would need to do that.

Usually EVERYTHING would be 192.168.1.x  OR 192.168.100.x, but not a combination of both…


#3

Hi Tony

Thank you for your reply. Of course 192.168.1.x and 192.168.100.x are two totally different networks. My network, where there are my computers, wi-fi phones, PS3, network DVD and Blu-ray players, is 192.168.100.1xx. (with  xx is from 01 to 99)

My Linksys router ( gateway) IP adress  is 192.168.100.100.

DNS is 192.168.1.1 ( from my DSL box).

The network works perfectly fine like this. Except the  WD TV Live :wink:

Thanks

Pascal.


#4

I just tried to plug in 192.168.100.99 and it did not have a problem with that (well, it won’t work, because my net isn’t configured like yours, but it didn’t say Bad IP address.

List ALL the parameters you’re using:

IP address:

Subnet Mask:

Default Gateway:

DNS


#5

IP address: 10.10.10.54

Subnet Mask: 255.255.255.0

Default Gateway: 10.10.10.1

DNS: 10.10.10.1

Youtube works and media servers too (sort of) but when I click on a shares nothing happens. What gives? Or is it because I switched from XP Pro to Home (don’t ask) which has limited network functionality?


#6

IP address: 192.168.100.1xx

Subnet Mask: 255.255.255.0

Default Gateway: 192.168.100.100

DNS: 192.168.1.1

I have a PC as a server at 192.168.100.101, running with XP Pro, with two drives shared. Those shares can be see by all the computers of the network, including the PS3 ( I have a DLNA server running on it).

In Automatic mode, the WD Live get this each time:

IP address: 192.168.1.32

Subnet Mask: 255.255.255.0

Default Gateway: 192.168.1.1

DNS: 192.168.1.1

It is impossible that it can get such IP because my router is set to have adresses between 192.168.100.100 to 192.168.100.199 ! However it can go to the net, get Youtube etc and don"t see NO shares at all.

If try to change manually to sometinh like 192.168.100.105 for example, I have a reply ’ Bad IP, please try again". How can you explain that ??


#7

My guess is there’s SOMETHING on your network acting as a DHCP server that’s providing that .32 address.   The WD isn’t going to make it up on its own…

OR,

There was a version of firmware some time ago which would now allow legal IP addresses, and it would give the error you describe on manual setup, but it was fixed.   I don’t remember what versions it was, but the release notes would tell you…   It’s possible that a DHCP providing the same IP address as one of those “illegal” ones would cause an issue, too.


#8

Hi again

Ok I found it ! Curiously my DSL box was also acting as a DHCP router and  the WD Live connected to it instead of the Lynksys router. It is the reason why WD TV Live has gone to Internet, but never saw the shared because they was not on this network !

I turned off the DSL Box DHCP router and set up manually an IP address for the WD Live into the good network. Now it can see the shared drives, and I can see it and its USB hard drive from any computer of the network !

Everything works perfectly now ! Many thanks for your help !!!

Pascal.


#9

Awesome.   Glad you got it sorted out.


#10

Well, my DSL box has the only DHCP running on my network, still I don’t get to see shares despite the LIVE being assing to the right subnet.


#11

Tech, are you asking for help, or just making an observation?  If the former, might want to start a new thread since this one is marked SOLVED already.


#12

Well, the former but since you were already reading this thread I was wondering what your take might be on this :wink: