I changed IP addresses, and now my files are gone. ☹

I am new here, and have had my MyCloudEX2Ultra working just fine for three years. I was going from one network to another and had changed the IP address to a static one in the GUI to be seen by the new network when the NAS seemed to have lost everything. From my Windows 10 system, I was able to see the NAS in the network and can access it via \IP.number, but when trying to drill down, it says the folder is empty. I don’t see how changing the IP address could have done this.

It’s been a week since I first contacted WD Support, but since I hadn’t heard anything from them after sending them my logs, I thought I would try here because it is my only hope. As background, I’ve been in IT for 40 years and although I am much more a Windows person, I’ve done enough Linux/Unix to be comfortable with commands, SSH, etc. I have spent hours on here searching for assistance, and I did find a couple of postings that helped, but the diagnosis is still unclear.

My setup is two 6TB drives, spanned, and the NAS was about 60% full. Now in the GUI, the main page states that I have 0KB free.

The disk status for both drives is healthy, as is the RAID health, but under RAID Volume, it just says “Set Up Raid Mode”, and I don’t remember if that is normal or not.

Under Utilities, the Scan Disk and Format Disk options are grayed out, and when I go to try anything in the GUI, it says “no volume found.”

I was able to SSH into the NAS. I do seem to have a complete list of folders that I saw in another post.

In the /shares folder, unfortunately, I don’t see a folder named “DataVolume” that I read in another post where the user’s files were hidden.

But what I do see that the other user did not have is what looks like my two hard drives, /mnt/HD_a4 and /mnt/HD_b4, however the listed size for each is way too small (928.9M). I looked in the /mnt folder and found what I assume are my drives, but they are each empty.

I know this looks like all the files are gone, but how can that have happened by changing an IP address? I have done the 4-second and 40-second resets (when I had WD on the phone) but they both promise that it only changes the admin stuff. I started going through config files but didn’t know enough about WD’s process to know what specifically I should look for.

I also tried to use UFS Explorer Standard Recovery, which was used successfully by another user. I assume they were plugging the NAS into their computer via USD instead of the network version, but I could not get my Windows computer to see the NAS via USB. There is a RAID/network version, but it couldn’t find anything other than my C drive.

Is there anything else I can try? Thank you for your time reading everything.

Hi @TrishaInNashville ,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

How long NAS on xxx.161 firmware?

Thank you for writing. Yes, I contacted Support over a week ago. In the end, I was able to figure out the solution. In the GUI, in the section for storage encryption, it seemed to indicate that the volume was not mounted. On my third email to Support, I asked if they thought that would be the issue and they said yes. After searching for the encryption password, I attempted to mount the volume and it worked! I still don’t know how that happened, but I am thankful to find a solution after a harrowing week. Thanks to all here who took time to read my story.

1 Like

glad you got it back working

I set my different NAS system to different IP address with no problems
so wanted to say just a IP change will be ok.

I do make a copy of the NAS config before changes : but that is never a BIG help.

I have to take a lot of pictures of the UI setting - before and after

1 Like