I can not connect my hard drive to macbook

Hi there,
I had to go to the forum because I do not know what else to do.

The problem is that when I connect my hard drive WD My Passport Ultra mac my computer does not detect this. Sometimes   it work, but disconnects constantly. I tried to format it with different file systems (HFS +, NTFS, FAT32 …) but it has not worked.

It’s something strange because there are sometimes that it work.

In windows it works perfectly. It’s a disk problem? I need help please.

Thank you very much and sorry my english

I believe it’s more related to the actual computer system itself as opposed to the operating system. Did you try it with other Macs for testing? If your Mac doesn’t have USB 3.0 ports then try with a Micro USB 2.0 cable (It can be used with the USB 3.0 connector of the WD Passport Ultra) in order to force USB 2.0 mode.


My mac doesn’t have usb 2.0 ports, only work whit usb 3.0,  and I buy this on June 2014, so it have te lastest OS (Mavericks 10.9.3). I haven’t tested if it works on other macs.

I found it on WD webpage http://wdc.custhelp.com/app/answers/detail/a_id/11005/p/228,195,470/c/123/session/L3RpbWUvMTQwNjc0MzM4Mi9zaWQvRXVBbVFCLWw%3D , but is doesn’t work. Maybe because I format to hfs+ recently?