Huge plex problem! incoming storm

So here is the run down for a long time My Cloud had a working yet very old version of PLEX (PMS) Version 1.0.1.2366. I and some others have been fighting for weeks if not months in the PLEX WD forum section trying to fix the HW Transcoding Artifacts in (ALL VERSION PAST 1.0.1) plex because the only good version is the old one.

Now today the My Cloud removed 1.0.1 and replaced it with Version 1.3.2.3112 which is probably the WORST version imaginable since not only do we still have a broken artifact rich Transcoder but it also does not include the option to turn off HW Transcoding like the newer versions do!

Again if you update to the latest PMS and turn off Transcoding the CPU core (Plex Uses only a Single core per stream) hits 97% leaving you with buffering and the dreaded rewind effect ( it works like this you buffer / buffer / buffer / then jump back 10 or 15 minutes in the show and then it plays fine tell it gets to the new parts of the show and starts over turning a 30 minute show into a hour long one yay!) There are a couple tweaks in the transcoding that did seam to help but I’ll save that for later if requested.

If you don’t like reading then here you go you can not update plex and stay with 1.0.1 or you can update and enjoy some artifacts.

This is from Version 1.0.1.2366 for the pr4100

And this is the latest Version 1.5.0.3501

O yeah and mods you have my permission to sticky this post to the top of this forums section.

Also if you are having these same issues please post here so WD can see its not only one or two people, the more that share their voice the quicker a solution can be made.

Have a nice day
Luther the VAN freakin Guard

So is there a download package available that we can use to roll back to the 1.01.2366 version?
Also, 1.5.0.3501 is a plexpass release, does the GA version 1.4 have these artifacts too?

I just removed the link do to the lack of interest in this thread, Its a shame really I was hoping the community would of rallied together to get the artifacts fixed.

you guys loving those artifacts?

No, cause I turned off the experimental hardware transcoding feature and the artifacts go away and everything works great.

Sounds like you are not using a PR4100 or a PR2100, the only time you avoid buffering when transcoding is turned off is when the device you are streaming to supports the video codec and thus does not require any transcoding.

I’m using a PR4100 and Apple TV and Roku and Xbox are what I stream to

With PR2100, plex version 1.7.2.3878, leaving the default checked (Use hardware acceleration when available) causes poor quality, with it un-check, it looks a bit better, but I think I still saw the message about not powerful enough to transcode. CPU was at 20%. Is there some logs I can read to understand more about the transcoding?

Thanks

I’m running a PR4100 with Plex Version 1.7.5.4035.

I’m getting absolutely nasty artifacts when hardware transcoding is enabled for H.265 encoded video. It ruins the viewing experience.

If I disable hardware accelerated transcoding in the Plex server settings, it looks ok but uses 99% CPU.

If I try to create an optimized original version, it uses 3x the disk space of the original, and still looks like garbage because the hardware accelerated encoder was used to create it.

One could probably disable hardware acceleration under Settings -> Server -> Transcoder, and then create optimized versions of videos and then subsequent plays of the new version would play fine.

However, these conversions can take a substantial amount of time. One I tried was roughly equivalent to the 1x play time of the video itself.
Another problem with this, is that if anyone wants to watch a video while this transcode is happening, hardware transcoding is disabled and will then use even MORE cpu which can has the potential to severely impact performance.

You’ll also be flipping on and off hardware accelerated transcoding all the time which will be annoying.

Could someone please just fix this?

I don’t know if it’s helpful at all, but I noticed this logging when hardware transcodes started:

libva info: VA-API version 0.40.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /mnt/HD/HD_b2/Nas_Prog/plexmediaserver/binaries/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_40
failed to open /data/jenkins/pms-deps-universal-v2/BUILD_TAG/linux-ubuntu-x86_64/output/pms-depends-linux-ubuntu-x86_64-release-c70cb28/lib/dri/hybrid_drv_video.so
Failed to wrapper hybrid_drv_video.so

You could also try to skip transcoding and just play your video on a device that supports the x265 codec…
Or just create your content in x264…

AFAIK, the PR4100 doesn’t have a hardware x265 decoder, resulting in a bad performance.
The transcoding feature is rather to provide smooth 1080p x264 L4+ to 720p x264 transcoding, with a lower codec complexity, in order to support older ipods, tablets, …

1 Like

I’ve been having the same issues and my wife, (who uses this the most and was the reason for this set up as it’s simple for her to use), is getting cranky… I tested Plex with a laptop and a large USB drive to get my wife used to watching videos with the chrome cast… She loved it so I had the brilliant Idea of finally convincing her to fork out some dough for a NAS which would stay on always and act as the Plex server as well. Worked well until I updated and from what I can see everyone else if having the same issues… the funny thing is I’m using low to medium quality files here and it still causes an issue. I don’t want to have to hunt around for a way to roll back the version but it I have to then so be it… Does anyone have a link to a site on how to roll back to 1.0.1.2366 and I’ll turn off updates, (or block them in the FW).

FYI, this bug is fixed in Plex 1.9.7. No need to roll back.

Current installed version is 1.10.0.4523… and I believe the issue is still present.