Hub doesn't like this studio's releases?

Hello all, first post here.  Bought the WDTV Live Hub on new year’s day of this year (2011/01/01).  It came with, and presently has, firmware 2.02.16 installed.

Am just finishing ripping my movie collection (~ 200 discs) as .iso files to a 2TB USB drive, which is presently attached to my computer, but will be moved to the hub when done.  As the movies were ripped I’ve been copying them a few at a time to my NAS, for testing with the Hub, so the reported results are with the movies viewed from a network share.

In general the movies have played fine and, although there is room for improvement, I have been pleased with the Hub.  However, certain movies simply won’t play from an .iso (I copied one to the Hub’s drive over the [wired] network, which was painfully slow, and got the same results trying to play it from there, so I don’t think it is a network issue).

What occurs is that the disc appears to be trying to load, but the screen soon goes black and remains that way until the BACK button is pressed.  I can get the OPTIONS menu and select MENU, but the disc menu doesn’t appear and the screen remains black until BACK is pressed.  And the strange thing is that, if I rip the same movie as  a directory structure (.vob files), it plays fine!

As more movies were ripped that presented the same problem, I began to see a common thread running through them.  It seems that each of the movies with this problem is released by Columbia (including TriStar, Castle Rock, etc.).  Every one of my movies which is a Columbia release (and no others) has this exact same difficulty.  [This means movies which as listed on IMDb for example, as produced by Columbia (or TriStar, Castle Rock, etc.), not ones which are simply distributed by them.]  Some examples are:  Blue Streak, The Freshman, Groundhog Day, Rudy, Spider-Man 1, 2 and 3, Starman, Stripes, and True Believer, among others.

Before posting, I did search this forum for Columbia, TriStar, and Castle Rock, and found only one possible mention in message 18 of this thread:

So the question is, can anyone confirm difficulty playing these movies (or other Columbia releases) as .iso files, though no difficulty as .vob files?  Further, can anyone confirm that this same problem exists (or does not exist) on any newer firmware?

I can’t confirm it…  I have all three Spider-man movies ripped, and they play fine…  (At least, they did the last time my kids watched it…)

You didn’t say what your source media is:   DVD or Bluray?

What are you using to rip them to ISO?

TonyPh12345 wrote:


You didn’t say what your source media is:   DVD or Bluray?


What are you using to rip them to ISO?

Yes, you’re right, sorry.  They are DVDs, ripped with DVD Decryptor.  The rips seem fine, and play on the computer without problem.

I would try the free demo of DVDFab or AnyDVD.

DVD Decrypter is SO OLD that it doesn’t support many of the copy protection “tricks.”   Both of the above are updated every few weeks.

I had no problems using DVD Decrypter.

However, an alternative is to use Passkey Lite and imgburn (PKlite creates a folder and imgburn uses that folder to create an ISO).

Photonboy wrote:

I had no problems using DVD Decrypter.


However, an alternative is to use Passkey Lite and imgburn (PKlite creates a folder and imgburn uses that folder to create an ISO).

The fact is that DVD Decrypter is out of date and cannot cope with newer copy protection. The last real release was in 2005!

Also passkey lite has severe limitations - 

“It can still decrypt protected DVD and Blu-ray, but not for all of them. For example, it can’t remove AACS V12+, BD+, BDAV, and AVCREC for Blu-ray, so you are not allowed to watch movies with those protections. It doesn’t support CPRM for DVD, and PathPlayer is not enabled, so ARccOS, RipGuard, FluxDVD, and CORE X2 can’t be removed. As a result, you can’t copy those still protected DVDs , but you are able to freely watch them.”

Therefore the best advice, as said above, is to use DVDFab (free version) which is able to rip the majority of discs.

“DVDFab HD Decrypter is part of DVDFab DVD Copy and DVDFab Blu-ray Copy. It can remove all the DVD protections and part of Blu-ray protections, and copy DVD/Blu-ray to hard drive”

Thanks for all the software recommendations.

Okay, I installed AnyDVD and ripped an .iso from one of the movies I mentioned earlier.  It performs exactly the same way as the .iso ripped by DVD Decrypter.  Plays fine on the computer, but gives the same problem on the Hub.  So, I don’t think the problem lies with the .iso or the ripping software.

What else can be tried?

Besides the author of the post I linked to earlier, has anyone else had difficulties with particular .iso files on the Hub?

Okay, this is interesting.  I’ve been finishing up my collection using AnyDVD.  I had a double-sided disc, dual-layer both sides, which had read problems (same results on two different drives).  The first side got to 99%, then aborted.  The second side got half way (i.e. near the end of the first layer) and aborted.

Out of curiosity, I copied the .iso files to my NAS, then tried to view them on the Hub.  Strangely, they gave the identical results as reported at the beginning of this thread.  Now I know these were bad .iso files, but I wonder if the identical results has any meaningful significance?

Do DVD discs have something similar to a CD disc’s finalizing?  And if so, could it be that the Hub would interpret a disc which wasn’t finalized as being incomplete, and thus yield those results?