HUB cannot see any media servers on network

I have an issue where my HUB does not see any of the media servers on my network. When I am selecting a content source, (for videos or music) if choose “media Server”, I get the error message “No content source available”.

I have several media servers on my network, but the specific one I am trying to find is my PlayOn server, which streams Internet media. The odd part for me is that both my Roku and my LivePlus have no problem seeing PlayOn and showing any of the channels. THe LivePlus actually sees 3 of my Windows 7 boxes as media servers (I have them setup as MS’s to test this issue) and can play content from them without any problems.

The HUB can find all of the other computers, including the one running PlayOn, over SMB and connect to them and play media from their shares.

I am out of ideas. I can push content to the HUB from PlayOn mobile on my Nexus7, and I can also use Twonky beam (thanks to mike27oct) to stream content to the HUB as well. It just does not see any of these devices on my network on it’s own without the media being pushed at it.

Am I missing a setting somewhere that allows the HUB to see media servers? As above, the LivePlus works like a champ and sees all of them just fine. (that is still a GREAT product if you don’t need a pretty front end)

Any idea greatly appreciated. I can continue to use the Roku for this purpose and still get the content to the same TV, but of course that is not really the right answer. I have to be missing something and it frustrating the #@$#! out of me :confounded:



that is a tough one, I’m sure you’ve checked all the basic

like master browser, subnet, etc …

a quick google, shows that playon server randomizes the ports used, at each start up

I would look into what ports are being used

maybe disable all anti-virus and firewalls, temporarily for testing

but you’ve probably done that already

Thanks for the tips KAD79.

Yeah, I did do the basic stuff. The fact that the HUB can attach to that machine over SMB says to me that there is no Master Broswser issue, and as well, I don’t think that would matter with DLNA/Media Servers. The Roku sees that box fine as well, and can even play local media from it (or can accept a stream of local media to it to be exact).

I’ll give it a shot shutting down the antivirus etc. The most puzzling part is that the LivePlus sees PlayOn.

Another part that I am sure is somehow connected, is that the HUB cannot see any Media Servers on the network, while the LivePlus sees 3 x Windows 7 computers that have media streaming enabled, PlayOn service (on one of those same boxes), and then of course the HUB as well for a grand total of 5 media servers that the LivePlus sees and can connect to. If it were not for that, I’d be sure that I had really messed up something on the network.

It’s like there is something blocking the HUBs request for media servers to announce their presence. I know that it can recieve over DLNA, since I can beam PlayOn and Twonky stuff to it from my Nexus Pad,

If no one comes up with any ideas that work, I will try and sniff the network and look for the HUBs request when I choose media server as a source. I am not that strong at understanding all the network traffic, but maybe someone here will be able to interpret it if I cannot.

Thanks for the help


figured you had done all that

of coarse, there’s the full reset option on the hub

this is definetely an odd one,

what I thought was really odd on google, is that playon randomizes the ports used

that can potentially be a big problem with firewall rules

image somebody sets up specific firewall rules

then after reboot, playon chooses a different port, which can cause the firewall to block it

I’m also no expert at network packet inspection

I’ve only used wireshark a handful of times, but we’re here to help if you need it

although the most useful packet capture stream would be from the point of view of the WD, which would require WDLXTV to gain access, run the capture directly on WD, then analyze with wireshark

had to do that a couple of times with the imdb movie trailer plugin for WDLXTV

next most useful would be to run packet capture on the router

Could it be a loose network cable, a hosed up IP at the Hub, a connection somewhere between router and Hub?


Have you tried a full reset? (just wondering)


@KAD79 :You can set the ports for PlayOn, and keep them static, but that part is really for the incoming stream through the router’s firewall. One the internal network, media servers should announce themselves when requests come out and then the client can attach.

I have it setup with a static IP on that machine, and then use ine specific port for the WAN based traffic. I use a rule on the router for portforwarding so the replies always get back to the PlayOn host server.

All that said, the PlayOn server end works fine. I get thousands of channels / on demand video with the it, and then can access it on my local network from everything but the HUB. I use the service on my Nexus Pad, Iphone, LivePlus, Roku and XBMC, as well as I can use it through a browser on all of the computers in the house. I am guessing that this is not a PlayOn issue at all. Since my HUB cannot see any media servers, there is something preventing that. If I take PlayOn out of the picture, the Roku and LivePlus can still access the Windows 7 machines over DLNA as media servers while the HUB does not see any media servers on the local network.

I think I made this confusing by adding the PlayOn part. The real issue is that my HUB does not see any DLNA servers. I assume once it can see the Win7 Media Servers, PlayOn won’t be an issue either.

And you are on the money about wireshark. That is the intended tool for this task if it get to that. I have refered to TonyPh12345’s post on how to use Wireshark to many time to count. It’s one of the best reference tools archived on this site and has helped me a number of times.

Here’s a link to Tony’s post for anyone who needs or just wants to do a bit of network sniffing

How to run WIRESHARK



Anything is possible, but I did check the network connections, and the HUB works fine for all aspect except this one. External media services run as expected, and all my media is on a fileServer connecting over SMB which works fine as well.  IP is static, and also protected at the router level. All the machines act as expected and play nice but this one issue.

Full reset I guess if probably the next step.


Dont know if it will prove anything but before the full reset tinker with the Hubs network settings in setup. See if going from manual to automatic, powering off, back on gets it going again. Then of course back to your original setting.

yeah, all the other working devices, basically confirm that it’s an issue with the HUB

hopefully full reset will fix  it