Http access to Public files

Hi

In the past I sometimes used the possebility to get files from my MBL using a browser

Example:

MBL at 192.168.1.200  >>Text file Example.txt in Public root folder

In the first 2.x Firmware version the file was accessable using http://192.168.1.200/Public/Example.txt

Since the latest firmeware Updates this is not possible anymore…

I’m always ask to provide a Username and Password for “DeviceUser”

I tried  all avalkable users … even root… without success

Somebody an idea how to get this access possebility back (I’m firm with SSH login…)

You can check the release notes for the latest updates, to see if this option was disabled. 

http://support.wdc.com/download/notes/My_Book_live_Release_Notes_FW02_41_05.pdf?v=9501

I had befor the update Firmware Version 02.02.02-020


Firmware Version 02.03.01-024
Resolved Issues:
• Resolved issue where files in private shares can be accessed without a password if the file
path is known

Unfortunatley they removed the possebility for Public as well =(

Try using webfs, it works great here on my local LAN

Do not forward port 8000 to the MBL in your router or ANYBODY will have full access to your MBL

SSH into your MBL with PuTTY or Terminal

apt-get update
apt-get install webfs

 Edit webfsd.conf

nano /etc/webfsd.conf

Look for

web_root=

and change it to

web_root="/DataVolume/shares"

Hit control and o

Hit enter

Hit Control and x

This will save the edited file and close nano

Restart webfsd

/etc/init.d/webfs restart

Enter your mybooklive NAME or IP:8000 into a web browser to access your shares

Sample PuTTY output

login as: root
root@192.168.1.6's password:
Linux MyBookLive 2.6.32.11-svn52288 #1 Wed Oct 26 18:57:59 PDT 2011 ppc

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

Disclaimer: SSH provides access to the network device and all its
content, only users with advanced computer networking and Linux experience
should enable it. Failure to understand the Linux command line interface
can result in rendering your network device inoperable, as well as allowing
unauthorized users access to your network. If you enable SSH, do not share
the root password with anyone you do not want to have direct access to all
the content on your network device.

MyBookLive:~# apt-get update
Get:1 http://ftp.us.debian.org squeeze Release.gpg [1672B]
Get:2 http://ftp.us.debian.org squeeze Release [99.8kB]
Ign http://ftp.us.debian.org squeeze Release
Get:3 http://ftp.us.debian.org squeeze/main Packages [6493kB]
Fetched 6594kB in 47s (139kB/s)
Reading package lists... Done
W: GPG error: http://ftp.us.debian.org squeeze Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY AED4B06F473041FA
W: You may want to run apt-get update to correct these problems
MyBookLive:~# apt-get install webfs
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  webfs
0 upgraded, 1 newly installed, 0 to remove and 260 not upgraded.
Need to get 67.6kB of archives.
After this operation, 279kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  webfs
Install these packages without verification [y/N]? y
Get:1 http://ftp.us.debian.org squeeze/main webfs 1.21+ds1-8 [67.6kB]
Fetched 67.6kB in 0s (213kB/s)
Preconfiguring packages ...
Selecting previously deselected package webfs.
(Reading database ...
dpkg: warning: files list file for package `ramlog' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libparted0' missing, assuming package has no files currently installed.
(Reading database ... 19010 files and directories currently installed.)
Unpacking webfs (from .../webfs_1.21+ds1-8_powerpc.deb) ...
Processing triggers for man-db ...
Setting up webfs (1.21+ds1-8) ...

Creating config file /etc/webfsd.conf with new version
Starting httpd daemon: webfsd.
MyBookLive:~# nano /etc/webfsd.conf
MyBookLive:~# /etc/init.d/webfs restart
Re-starting httpd daemon: webfsd.
MyBookLive:~#

Hi

I found a way to access the files in a little bit different way.

First I have created a Softlink from Public >>Public2 in folder share.

I usedMC to navigate to edit  /etc/apache2/sites-available/wdnas

I Inserted the following lines BEFORE

Alias /Public2/ “/shares/Public2/”

      <Directory /Public2/>

            Options -Indexes FollowSymLinks MultiViews

            AllowOverride None

            Order allow,deny

            allow from all

File saved

After Restart of Apache i was able to access the files via http:///Public2

Nice, thanks for sharing your solution :slight_smile:

Is webfs better than the standard (or even modded) Apache file listing? Does it allow to download whole directories as zipped files?

For example, with the h5ai apache mode, you could do that, plus several other stuff (QR codes, uploads, renaming/delete, thumbnails, text reader, etc.). I know webfs is meant to be simple and might not do all that, but what I care the most is about downloading zipped directories.

I’ve searched for screenshots or more features and there’s nothign (beside the official site). And I can’t install it myself since my MBLD is currently bricked.

Thanks

webfs is very vanilla… I mainly use it to stream video and audio to my tablets and keeping track of downloads on my datavolume from a tablet or phone.

It doens’t allow zip download of full directories?

And how does it manage security? You say that you control your downloads from your tablet (unless you mean in the LAN), it doesn’t seem to work with user accounts since the documentation says it doesn’t even have a configuration file.

The thing I have done is to install and configure the h5ai Apache template. It customizes the default directory listing adding a lot of cool stuff, like:

  • Download directories as zip! :slight_smile:

  • Image thumbnail (this didn’t work in the MBLD, so I installed PHP5-GD addon and it bricked)

  • PDF Thumbnails

  • Video Thumbnails

  • Uploads

  • Delete/Renaming of files

  • QR codes for each file on mouse hover

  • Sorting, filetering, directory tree, breadcrumbs, etc.

If you are interested I’ll post (as soon as I debrick) all the stuff I changed to make it work.

You can see a live demo on the author’s site  here

Nope no zip downloads of full directories, and yes there are no user accounts so LAN only. It has a small config file and I point it to the datavolume and am able to browse around to see progress of downloads from my tablets web browser. I can also click on an .avi .mp3 and such and if my tablet supports the files it starts playing them from a stream from webfs.

Please do create a guide for your mod as it souds great!

OK, I will as soon as a regain access to my bricked MBLD! :wink: Today I’m going to buy the SATA dock and hopefully restore the images correctly.

I’ll work on the guide then and let you know; maybe with your expertise on installing packages we could work out those “unsupported” features that the template shows because it’s missing the apps in the OS (and that’s the reason I bricked my MBLD, when trying to install them!)

nfo, have you ever tried installing, other more advanced file servers? Like php Explorer or eXtplorer? I’ve tried and failed with both :(, but it would be great to have something like that running on our disks

No I haven’t as these kinds of programs always have dependencies that seem to break the MBL dashboard. I’m not saying it’s impossible though