How to use WD "My Passport" with Ubuntu Linux

Western Digital’s documentation is very explicit that it, Western Digital, knows nothing about Linux. It only mentions that there may exist “generic” drivers. Not aware of that problem – it is not mentioned on the box – I bought a WD “My Passport” external hard disk. I plugged it into my computer running Ubuntu Linux and immediately saw that Linux could read and write the disk. So I would not have to reformat the disk, as do the poor Mac users. The only question was to find appropriate, reliable, free software to manage the backups.

Aware that:

    Anything Windows can do Linux can do better,
    Linux can do anything better than Windows,

I set out to find out what Linux had to offer.

The answer – or at least one of a number of answers –  is _ rsync _. It is well explained in Ubuntu Community Documentation, which you can see by clicking here. You should read before going further here.


My system has the complication that it has dual boot and a Windows partition.  The first job was to find out what Linux calls the Windows partition and what it calls the external USB hard disk. So I opened a Linux Terminal, and did:

cd /media

I immediately saw that the external drive was called “My Passport” while the Windows partition was called FC32282f3227ECF8. So I did

cd /media/"My Passport"
mkdir LinuxPartition
mkdir WindowsPartition
cd /
sudo rsync -azvv /home/ /media/"My Passport"/LinuxPartition
sudo rsync -azvv /media/FC32282f3227ECF8/ /media/"My Passport"/WindowsPartition

Each of the last two commands may take quite a while when first performed and every byte has to be transferred. Later, rsync figures out what needs to be transferred and the process goes much faster.

The commands above back up Windows itself but do not back up the Linux operating system itself, because it is available on the live CD.

If I may offer a word of unsolicited advice to the folks at WD it would be this: Don’t make yourselves sound ignorant to users of your products who have found that Linux is not only virus free and rich in useful, free software but is also easier to use than Windows. Get Linux, play with it, and offer a few words of helpful advice to users of your products with this superior operating system. You don’t need to write any software.


Sweet dude :smiley:

will give a second thought to a dual boot partition I have been considering for a while…

I will give this a try and post back  my experience…

Thanks for this valuable info

You can install and boot Linux from the “WD My Passport”, I have the one with USB3 500GB. I had some problems with the Grub2 boot however (Ubuntu 11.10 64bits). Symptom: the Linux installed without problems, but it did not boot (no Grub message, just a black screen with a clipping cursor). The same installation did boot on 2 recent systems (USB3 and USB2), but failed on a third system 3 years old (USB2). I tried to repair the grub on the third system but without luck. I tried to reinstall the Linux, it installed without errors but it did not boot correctly.

It seems that on some BIOS versions the boot partition needs to be at the start of the disk (below cylinder 1023). On other BIOS-es, I could install the grub files in a partition at the end of the disk. To be on the safe side, you should use a boot partition at the start of the disk, below cylinder 1023. It will be maximum 8GB, so you will need a separate partition for the root. After this, it worked well on my USB2 system (Asus K52JR). I have the last firmware 1.010

First I thought that the problem is related to the SES device that seen in the boot menu along with MyPassport (the actual disk). However, the solution to make the boot from USB to work is just to create the small boot partition at the start of the disk.

Hope this will help. For some reason I could not “Reply” on the topic regarding “How to boot linux from My passport” (disabled button)