How to remove write-protection

I have a “My book Essential” (External Hard Drive)

I want to copy some files from my laptop hard disk into it. (As I got answer to my previous post, I already uninstalled WD software, in order to be able to copy/paste files into it)

It gives following error message:

Error Copying File or Folder

Cannot create or replace …: The disk is write protected.

Remove the write-protection or use another disk.

How can I overcome this problem?

1 Like

I am having the same issue exactly but nothing I do seems to help and no post I have found here or anywhere else has made any difference.  all I have found is a bunch of problems with it.  Has anyone found anything?!?

I have same problem with write protection. I have found no solutions to this either.

I had the same problem.  I think my is working now.  I error-checked using windows.  It found a couple of bad areas, repaired them and it works fine so far.

I hope this helps you because I know what it is like to try and fix something that is not supported well.

Thanks. I also solved my problem after many try and error.
Now it works fine.

1 Like

A clue here,

my drive just went read-only.

I have the drive on Ubuntu 8.10, it is NTFS, but I’m not sure how I would check the fs without having to reboot in Vista, that is worth a shot. I suspect that the drive became slightly overheated, but doing s filesystem check  for NTFS under Ubuntu would be better. It is true that disks will go RO if there is fs corruption, although Ubuntu said it had mounted it RW.

I was able to fix this, but I couldn’t do it with ntfsfix inside Ubuntu 8.10 ( Linux). That failed and said to run ckdisk. I rebooted into Vista and did the filesystem check. It said that it found some lost blocks. When I rebooted back in Ubuntu I was able to get back write-access.

This incident raises several issues: Is the disk hardware vulnerable to failure due to heat? Is NTFS robust enough, including the WD Software? I am using Linux, so that means that the software may not be mature enough to catch some anamolies.

My guess is that these drives may fail-protect to RO due to heat. Can the engineering people at WD reply?

The other issue is, has a foreign filesystem type, like ext3, been tested on this device? I am tempted to slice the disk and set up a few ext3 filesystems. Anyone comment?

Bruce Salem


My guess is that these drives may fail-protect to RO due to heat. Can the engineering people at WD reply?


The other issue is, has a foreign filesystem type, like ext3, been tested on this device? I am tempted to slice the disk and set up a few ext3 filesystems. Anyone comment?


Bruce Salem


The forum was created for users like yourself to share ideas and tips.  It’s not a support forum, nor do engineers cruise it.  If you really need help, you will need to contact Tech Support, and you can do that by email or phone.

I can tell you that right now we do not test our drives on Linux operating systems.  However, that may change in the future as Linux continues to gain popularity.  But you should keep in mind that we only state that these drives are compatible with certain Windows and Mac OS’s.

To Contact WD for Technical Support

Thanks. I knew I was on the ragged edge with WD 1.5 TB and linux, but it has NTFS support, and I can put up with the modest performance hits I see. I am only using the drive as a secondary storage.

Since I am using the NTFS support only in Ubuntu 8.10, such as it is, I am not using the WD Smartware stuff at all, so I expect that my use of the WD is not optimal. I havn’t had the FS go RO. due to corruption, but once more and it was sufficient to boot into Vista but once to fix that, the partition came up clean, which means vista must do a filesystem check when it mounts the device. I havn’t had any problems since except that I notice that the drive has to be “kicked” to do a disk usage (du) in linux. Remember that NTFS is POSIX compliant so that it should understand how to provide info to the du command in Linux.

Quite often if I update the FS, the drive will not respond to du equivalant function in the file manager. I use nautalus under gnome. I need to go up to the containing dir or even the mount point with the file mgr. to persuade the drive to update the property I’m seeking, namely the size of a subtree. Actually what I am saying is not strictly accurate.  I am only assuming that the file browser calls du. The issue is that the drive does not tell the file manager what it is asking for right away. It needs to be persuaded. As I think about this, I realize that maybe I need to try all of this from the shell in a terminal, and see if the drive responds better there than in the file manager. It could afterall be a natalus problem. I say all of this to help the engineering guys deal with linux.

I think that this is a variant of the complaint that the WD drive is slugish or not responsive.

Bruce Salem

Not sure if we are experiencing the same thing but I had similar symptoms on a Windows Vista pc.  This doesn’t sound like the issue the linux folks were having.

I installed the drive, let it do the initial backup etc without problems.   The next day I went to copy a file directly to it and got the write protected message.   Drive properties, security properties etc. all showed that I should be able to write to it.

What I eventually found was that it was protected by the drive security encryption.

I opened up the WD Smartware software and the drive status showed that it was locked.   Clicking on the drive icon prompts you for the security password and the drive was available again.

I haven’t experimented yet to see when it gets locked down but I suspect it does when it goes into power save mode.

One concern I have is how will the automatic file backup work unless each of my family members goes in and unlocks the drive before they make any file changes which is unrealistic.


This may be a big help since it worked for my WD passports:

I had that problem after uninstaling the worthless Smartware. I finally went into device manager deleted the driver and rebooted system. The fixed it for me.


I simply unplugged the external drive. when plugging it back in, the WD SmartWare will show (not the actual drive). Open this and select unlock.  I set up this password when first  plugging in the drive the first time. I am now able to write and delete from the files on the HD.

1 Like