How to Remove Empty Folder from WD Photos


#1

I added a large folder of pictures to /Public/Shared Photos - for example called it Folder1.  I renamed the folder to Folder2.  Now I see Folder2 with my photos and Folder1 (the original name) as empty.  Will the empty folder eventually disappear or do I have to do something specfic somewhere to remove it from WD Photos?  I have cleared the cache on the mobile device several times.


#2

I appear to have solved this problem myself - and probably caused the problem as well.  I copied a folder of 500 or so photos into the Shared Pictures folder.  After copying it - I did not like the name that I used and renamed it several times - probably while the photos were being “converted”.

Somehow I ended up with an empty folder (of the original name) showing all the time in the WD Photo App.  The folder stayed there empty for several days.  It would continue to show after clearing the cache - couldn’t see it anywhere on the drive or anywhere in Twonky (not sure if Twonky is related to WD Photos - but I suspect it might be).

What I ended up doing was to create a new folder in Shared Pictures with the same name as the one that was showing as empty in the WD Photos app.  I then moved a couple of pictures into it - and the pictures quickly showed up on the WD Photos app.

I went back into Shared Pictures and deleted the folder.  I then waited a while for the folder to disappear from WD Photos which it did in a matter of minutes.  Everything seems to be okay now - as I can rename folders, combine and manipulate them - with.WD Photos correctly reflecting the changes after a short while.


#3

I just tried this last night… Can be reproduced and solved exactly as you posted so I’d call it a bug.


#4

Interesting - I believe that I tried to reproduce the problem (after I had figured out how to fix it) - but was unable to get it to happen again.  Apparently you just did whatever it was that I had done - at the time - to create the problem - and were able to use my problem to fix it.  Anyway - this particular problem has not resurfaced.


#5

Sorry Guys, this has NOT worked for me!!!

I had a folder on there called “olf nacked iphoto” It contained 11244 photos. It was a folder I was using to consolodate all of my pics scattered around all my old hard drives.

I deleted it months ago, but it still shows up in the iphone wd photos app.

I have tried recreating it, renaming it, deleting it,

I still get "File not found. (404 17.26) everytime I access the app.

I have reinstalled the app, done a firmware upgrade and still the same problem.

HELP


#6

I see you have spaces in the folder name.  Is there any possibility that you have accidentally typed a non-printable whitespace in either the original folder name or in your attempt to recreate the folder so that you can delete it - or have you mispelled the folder name in your attempt to recreate and delete it again?  Just a thought.

~Scott 


#7

Also - have you tried removing the mobile device from remote access and re-adding it again with a new access code.  I’m not sure if this will help but you could also try removing mobile devices, disabling remote access on the MBL - then shutdown the MBL - physically unplug the power to the mbl - and leave it unplugged for about 20 minutes (supposedly this will clear out any cached information that may be residing in the MBL).  Then boot up the MBL - reenable remote access - and setup your mobile device again.  Also be sure to clear the cache in the app on the mobile device as well.

In my case - I was using WD Photos with both an iPhone 4 and an iPad2 when I was having this problem.

~Scott


#8

One more thing that just might fix your problem.  If you are on the latest version of the MBL firmware:  02.10.09-124 : Core F/W  - there is now an option to rebuild the WD2GO Database (which is also used by WDPhotos.

To find this option - open the MBL UI  - goto Remote Access Tab - Click on Advanced - and then Click on the Rebuild button for the WD 2go Server.

~Scott