How to mount MBLD hard drives in RAID0 on a linux machine to extract data?

Greetings!

I’ve got the yellow light on my WD MBLD 8TB version after a power outage, right now it doesn’t start up. I am running RAID0 on it. I am trying to mount the drivers on a linux machine to recover data but there are so many spread out commands on the web and I am not able to find one list that could help.

Here you can find the screenshots from the disks which I could take on UBUNTU https://photos.app.goo.gl/dRZV7N8a5FbMBbkF7

I got a machine and connected both drivers on it using the SATA interface. I am running UBUNTU 18.04 from a USB disk in this machine. I was able to mount something (not sure if that is correct) however the DataVolume seems to be empty (which is not, for sure). Please find the steps I tried below.

root@ubuntu:/home/ubuntu/Desktop# sudo su
root@ubuntu:/home/ubuntu/Desktop# apt-get install mdadm
root@ubuntu:/home/ubuntu/Desktop# sudo mdadm --assemble --scan
root@ubuntu:/home/ubuntu/Desktop# cd /dev
root@ubuntu:/dev# ls md* sd*
md0 md3 sda1 sda3 sdb sdb2 sdb4 sdc1 sdd1
md2 sda sda2 sda4 sdb1 sdb3 sdc sdd

At this point I picked md0 - I am really not sure that is the right one neither how to identify the right one

root@ubuntu:/home/ubuntu/Desktop# file -s /dev/md0
/dev/md0: Linux rev 1.0 ext3 filesystem data, UUID=eb81d2c5-8d9f-4e13-a0a8-deb9476729a6 (large files)
root@ubuntu:/home/ubuntu/Desktop# mount -o ro /dev/md0 /mnt/disk1
root@ubuntu:/home/ubuntu/Desktop# cd /mnt/disk1
root@ubuntu:/mnt/disk1# ls
bin DataVolume etc lost+found opt sbin srv usr
boot debootstrap home media proc selinux sys var
CacheVolume dev lib nfs root shares tmp

Nothing here

root@ubuntu:/mnt/disk1# cd DataVolume/
root@ubuntu:/mnt/disk1/DataVolume# ls

Nothing here

root@ubuntu:/mnt/disk1/DataVolume# cd …
root@ubuntu:/mnt/disk1# cd shares/
root@ubuntu:/mnt/disk1/shares# ls
root@ubuntu:/mnt/disk1/shares#

Would you guys please help me? Thanks.

I am not sure why, but I ended up on connecting both drives to a windows 10 machine and running ZAR (I got it from here https://www.z-a-recovery.com).

Click here to see the ZAR reports

As you can see on the screenshots below It found 3 RAIDs

  • 1 Span 8 TB (this is the one I am interested on recovering the data from)
  • 1 RAID 1 490 MB
  • 1 RAID 1 2 GB

I should have mentioned I ran that debrick process found http://mybookworld.wikidot.com/forum/t-607715/debricking-script-for-my-book-live-duo because I read somewhere somebody was able to debrick and get the data on a RAID0 device. There may have been the reason why there are those 2 RAID 1.

Well, back to ZAR. As you can se all my data is there. Here are some questions:

  • Is there a way to debrick the device without losing that data? How can I do that?
  • If I can’t debrick it, how can I mount that span/RAID0 using UBUNTU so that I don’t have to pay for the ZAR software to recover the data?
  • If I can’t debrick, then I will need a kind of temp transfer storage. I have a second MBLD 8TB running RAID 1. Can I get one the disks (A or B), format it as NTFS and use it to help transfer the data OUT of the bricked device and back to it after debricking and put it back on the second MBLD where it is right now? Will I have any problem to add it back or does it rebuild the RAID 1 automatically?

Really need your help, guys!
Thanks

I’ve bought a license for ZAR x and was able to extract all the data for my bricked raid0 disks (let me know if you want some how-to since I’ve documented everything). I’ve ran the derrick process now I get the NAS up and running again, in RAID0.

I am copying the data I’ve extracted back to to the NAS using the Files program in UBUNTU. The HDs which the data is are connected to the UBUNTU machine’s SATA interface. The machine running UBUNTU and the NAS are connected to an isolated (no internet connection, no wi-fi enabled, no other device connected to it) Apple Airport Extreme with CAT6 cables. The best data transfer I get is 38 MB/sec.

Siince it is lots of data (almost 8 TB) I need to get better data transfers, otherwise this thing will take me a week long to finish. So here is the question: is there a way to mount the now OK raid0 drivers in the UBUNTU machine so that I can copy the data TO IT from HD to HD?

Thanks.