How to manually update rsync via ssh

Hi! I have My Cloud EX2 Ultra running the latest firmware 2.31.204
It has rsync 3.0.7 installed.
I would like to use the latest rsync version 3.1.3, which has --info option and other cool stuff.
Question - how can I update rsync package? apt-get is not available.
I saw some pages talking about chroot as solution, but I was not able to find a good explanation for my Cloud EX2 ultra. There is no apt-get option in the terminal.
Question: how can I update rsync / install other binaries using apt-get or any other method from ssh?

I done some experiments described here: but I cannot intall WD.Crack app.
Error message:
Failed to install app.

Tried Firefox & Chrome, tried also WDMyCloud_WDCrack_1.2.bin - no luck.
Disabled successfully APP_INSTALL_FUNCTION=1; APPS_EULA=1; check_app_eula(); via javascript - I do not get the popup window anymore.

Any ideas? Thanks!!

First off are for a completely different model not the EX2 so that is the reason for the failure you experienced.

To upgrade rsync you would need to find the new rsync tarball compiled for ARM or build it your self on an ARM machine with a working Linux compile process or non-ARM linux machine with an ARM cross compiler.

Many thanks, thetick! Understood! I was able to find MyCloudEX2Ultra_ChrootedDebian_10.0-1.bin and install it via standard app installation. After that I connected to it and was able to install and use needed rsync and rclone versions.

Yes that is a much easier then maintaining your own build . Fox-exe did all the hard work creating the Chroot Debian app :slight_smile: