How to disable HDD head parking?

Hi, I have a 3.5" WD hard drive connected to my computer using a SATA to USB adapter to my Windows computer.
I am using it as a secondary/external hard drive, it is not my main internal hard drive.

When I don’t access that hard drive for some time and then I go to access it,
I have to wait a few seconds to several seconds for it to load, like it takes some time to start up again properly (powering up kind of sound).
I believe this is caused by something called headparking?
How can I disable or change how long until it head parks?

I have tried using the “AAM/APM Control” feature (AAM set to OFF and 00h) in the software “CrystalDiskInfo” which I believe works in disabling head parking for my internal hard drive and other externally connected hard drives but not this WD hard drive.

Or is this caused by something else?

I don’t know for sure this will help but it might:

Windows Key+R copy and paste without quotes
control powercfg.cpl, ,1” <REMOVE the space between the two commas as this stupid forum won’t let you put them side by side!

Windows 10 includes the USB selective suspend feature that lets you automatically put USB devices in a very low-power state when they’re not actively in use. It’s an important feature because it helps prolong battery life on your laptop or tablet, but it may also cause problems with certain peripherals connected to your PC.

Advanced Power

Hi flhthemi, thanks for your reply! :slightly_smiling_face:

Not that it matters but I’m on Windows 7 but it seems I have already set turn off hard disk
to something like 999999 (this is virtually the same as setting it to Never?).
Does this setting only affect the main internal hard drive? The WD hard drive I’m using
is a desktop 3.5" which I’m using as an external hard drive (although it doesn’t have an enclosure, it’s just a normal HDD) connected to my PC using a SATA to USB adapter.

You have this setting in 7 too. If you use a zero instead of 99999 that definately will work. I think when you enter zero it’ll show the word NEVER when you save it. Don’t know if it affects other drives like USB…I would think the USB setting I mentioned MIGHT do it.

I also don’t know if the " control powercfg.cpl, ,1" will work in 7 but you can get there from “advanced” settings in the power options from Control Panel.

I set the turn off hard disk to 0 which now makes it say Never.
I also set USB selective suspend setting to disabled but I don’t think it made much of a difference. :thinking:
It still does a spin down (I believe that’s what it’s called), it spins up when I access the drive after some minutes of inactivity.

Well I tried…I don’t know what else you could do or try.


1 Like

Thanks anyway. :slightly_smiling_face:
Do you know anything about or know how to use the software called “WDidle3”?

The solution that works for me is to install HWiNFO64 and let it run in the background. it regularly scans all hard drives even USB ones and prevent them to go to sleep. You can also adjust the scanning interval in its settings. When you want the drives to go to sleep just exit the HWiNFO app.