How to delete Cloud Devices in the dashboard?

I have only 1 4TB My Cloud and somehow over time the dashboard now says Cloud Devices 4. I have tried to delete them from the iPhone app but they spring right back.

Thank You

delete the app and reinstall it. Do they reappear again?

I have deleted the app on my iPhone numerous times and they still reappear. I even still show a My Book Live Duo that I no longer have.


Do they appear as devices you can add or as connected devices?

On the Dashboard software on my Mac is says Cloud Devices 5. I only have the one 4TB… On the iPhone when I 1st download the app it lists all of them I pick one and it says cant connect. After I choose one of the 5 it let me access that drive remotely. 4 are not active


The cloud devices listed under a certain user in the remote access tab of the UI is the list of devices that have been used by the user to access the NAS, it is not the list of NASes.

It is possible to remove devices from the iOS app. Click on the small +/- sign on the top right of the list of devices. Press the red circles to delete the unwanted devices.

Thank you Etupes,

I have tried to delete them using your instructions in the past and they disappear for 1-2 seconds then show again in the app.


Hmm… It looks like there is some remnant of information somewhere, and I would expect it is stored on the NAS. Wild guess… Did you try to remove the devices listed in the UI for each user? If that doesn’t change it, did you try to remove remote access for your users and recreate it? If that doesn’t solve it and your are still annoyed, you could do a factory system reset. This will not delete any content, but you will have to reset your user share access.

Try to open the wd2go and see if they are present ther. If, then you can delete those you cant access.