How to delete a folder on My Cloud

This is probably a very basic question, but here goes -

I created an extra user account that I didn’t need, and later deleted it.  On my network, however, there is still a folder under that account when I open it in Windows Explorer.    In other words, I designated the My Cloud as drive “Z”.  Under drive Z, there is a folder for “John” - an existing user - and a folder for “John1” - the deleted user.   However, when I right click the “John2” folder, there is no option to delete it.  Pressing the delete button doesn’t work either.   How do I get rid of that folder?

BTW, I’m on Vista x64, and acces the drive remotely on a Windows 8.1 ultrabook.


You’re confusing folders for shares, I suspect.

Log into the cloud UI and go into the shares section and delete from there.

1 Like

That did the trick - thanks!

Having similar issue.  The folder/share doesnt show up in the dashboard UI though.  Tried to create a folder and it spit an error at me and wouldn’t create.  went to the address and the folder that i was trying to create was there, but doesnt show in the UI and wont let me create it.  Is there a way to delete it and try to make it again?

Reply to: Phantasm

Are you trying to create a share in the dashboard or a folder underneath a share you have. In the photo below you will see Horace, a share created in dashboard, clicking on the File Options icon I can create a New Folder. Is this what your did?


Opening up the Horace share by clicking on the + sign shows all the folders underneath that share then you can click on a folder>File Options icon and choose to create a New Folder. Where you tried to create the folder would help.

Pictures are worth atleast a 100 words. Image 4 has the folder I’m trying to delete.  It errors when I try to create in UI.


Reply to: Phantasm

See the image below, this should help you delete this share. Remember the Share and all its contents will be deleted.

The folder is not available in the UI.  I tried to create it last night and it gave an error and didnt create, but some how created in the cloud folder here. 4.PNG

Trying to delete from here so I can try to create again in the UI, but it isn’t availabe in the UI.



If you can’t delete a share from MyCloud dashboard you can directly delete it via SFTP using WinSCP (or via command line with putty or similar tool):

  • Enable FTP server in MyCLoud dashboard.

  • Enable SSH from MyCloud dashboard.

- Install Winscp and launch a session (login) in SFTP file protocol; user and pass by default are “root” and “welc0me” “0” is number zero.

  • On the right panel navigate to /DataVolume/shares, there are all your shares in MyCloud.

You can delete shares (folders) directly from there.

If you need more help about this just ask…  

1 Like

Had to reboot the My Cloud unit afterwards and it worked like a champ.  Thanks

1 Like