How to decrypt a WD MyBook drive after its removed from the enclosure?

Well if you had the same problem as I did, you probably have already taken the hard disk out of its enclosure and connected it to your computer. But if not, you need to first open the closure and take out the hard disk inside. There are a few DIY tutorials on how to do that. Be aware that this will void your warranty.

On the PCB board connected to the HDD, there is a chipset with a number on it. You need to see if that number matches the numbers Thomas has mentioned in his PDF file:

JMicron JMS538S
Symwave SW6316
Initio INIC-1607E
PLX OXUF943SE

But if you haven’t opened the enclosure yet, you need to describe exactly what went wrong with your external hard drive. Maybe I won’t be able to help.

I just have the drive. Enclosure was trashed.
Data recovery services have been unable to access the data without the enclosure.
Will Thomas’ solution to access the data without enclosure?

Keith Grandolph

Knowing the chip number would’ve helped us to know which code to use. Now we should try all possible codes to see which might work. That is if your encryption chip was among those 4 in the beginning. But sometimes it does worth the try, as the data are very much valuable.
Please send me your whereabouts to my email to see if sending the HDD is an option.
alireza.ershadi.uk@gmail.com

I need your assistance, thomas, can you help me?
I don´t have the case anymore, the disk works fine but cannot allocate a letter to be accesed
Thank you
Cesar
cesarolmos@yahoo.com

Hello guys.

My WD My Book enclosure died, and when I connected the bare disk to Windows, it shows that has to be initialized blah blah. Reading all your posts, I realized that the MBR got corrupted.

But, unlike everyone, I don’t care about the data. The disk was used to take daily data backups, but I’m also doing off-site backups, so I only need to get the disk decrypted and ready to use on another system/enclosure, even if the data get lost.

Is there any way to just decrypt it?

Thank you all!!

1 Like

Hello Master of the Wind. Im also searching for someone that can decrypt my mybook.

Hey Thomas - First of all good on you for being so generous and helpful to strangers. I know this post is 5 years ago, but I haven’t found any better source. Are you still available to assist on this type of recovery? I of course am happy to pay you for your time. I have a Mybook Live Duo network attached. I have the drives out, I have an OWD dock drive, but it wont mount for the reasons you already know.

Appreciate any response at all if youre still out there.
Thanks,
Blake

I was told by WD phone support that if I were to find the same enclosure for my My Book Duo Live, and placed my drives in there, it would try to rebuild the RAID immediately and wipe the data. This seemed odd, do you know if this is correct?

I do not. Have any data recovery companies diagnosed the drive?

I have the same issue with a wd mybook essentials. I tried to connect directly by sata to the pc. The disk it’s unknown for windows disk utility, and i tried to initiate by gpt but only recognized a raw system file. It’s possible to do the same system? Or if i did the initialization gtp process it’s impossible to acces to data? I didn’t format the disk, it’s only in raw system.
(I read this post later of initalizating the disk…):sweat::sweat:

I have the same. I put the drives in 2 separate USB drive bay instead of the original WD2000H2NC-00

Windows sees the drive Disk Partition, but no dive letters are assigned and no NTFS file system at all.

Can I just re-initialize the disk to be used again?

Kind regards,
Robert Kousbroek

Sure, you can do that

If you’re using Windows Disk Management, and it can’t do it … use a Free 3rd Party Partition Software solution eg. Aomei or EaseUS

1 Like

Thanks. I was worry the disks are unusable as they were first belonging to the WD Mybook.
That I can’t read the previous data is not so important.
Just want to reuse the disks.

Thanks for your tips

Kind regards,
Robert

hi bro. how do i contact you? i really need help from you. :frowning:

My USB to SATA controller board also packed up. Connected to my PC through SATA thinking it should be no issue and of course I came to realize it is encrypted. What is the latest recommendations here? I believe form what I read here that I messed up the MBR by plugging into a Windows machine directly. Any assistance would be greatly appreciated.

I have a My Book WDBFJK that I unplugged from one PC and plugged into another (and unpluged power supply as well). I did the “safely remove drive” from Windows 10 first. Now the drive is assigned a drive letter (D:) but after scanning Windows reports “D:\ is not accessible The file or directory is corrupted and unreadable”. This happens on new PC as well as plugging back into old PC.
I’m not sure where to begin. Is this a sign the encryption / hardware controller has failed? Or should I attempt file recovery software? I’m hesitant to do anything at this point for fear of making it worse (waiting for WD support response).

So far, WD support gave me nothing other than to send it somewhere. I’ve asked some specific questions and don’t know if they will be answered. Since the drive does mount in windows and is assigned a letter, I was able to examine properties - it shows used and free space as 0 bytes. Hardware shows two devices: TEAM T253X2001T and WD My Book 1230 USB Device. Can anyone point me in the right direction if this is a hardware failure with encryption or a directory issue on the drive?

Thank You all … Today I am finally able to retrieve my encrypted data from the 3TB WD My Book which I am trying to recover for 4 years. Thank You GitHub - themaddoctor/linux-mybook-tools: tools for opening some encrypted WD My Book drives in linux
Thank You so much, everyone …

hi @thomas_kaeding

i need help with my book and decryption data.

can you contact me in jiri.cipera@skoda-auto.cz ?

thank you