How do I show custom thumbnails for root folders in videos?

FYI, I access my videos via “Local Drives” icon. Then there is an attached USB external hard drive and also network shares (“nfs” and “cifs”). There are about three parent/root folders in total. 1 = USB drive; 2 = “nfs” network share; 3 = “cifs” network share.

When I click on “Local Drives” Icon, it shows the folders for the USB drive and network shares but I don’t see my custom thumbnails for these particular parent/root folders. But when I click on any of these folders, I do see the thumbnails for all the subfolders.

For each parent/root folder, I have a .jpg file located in the root directory of each folder named after the same name as the parent/root folder. For example, my USB hard drive’s name is called “Videos1” and the .jpg file is called “Videos1.jpg” and is located at the root of the drive. The same goes for my network shares; their corresponding .jpg files are in the root directory of the shared folder with the same name. For instance, the “nfs” network share folder is called “Videos2” and a “Videos2.jpg” file is in the root directory of this network share.

I also tried changing the jpg files to “folder.jpg.”

All folder thumbs must definitely be named “folder.jpg” so forget the custom names.  They also must be located IN that folder, so that every folder would have “folder.jpg” immediately in it.

After you’ve done this, delete the small WD file/folder on your attached USB drive (so it can rebuild the thumbs) and you should be okay (assuming your thumbs aren’t bigger than 70K or so).  However, be aware you cannot (no matter what you do) eliminate the very very root folder of your net share or attached drive (which is to say you’ll always have at least one root folder that shows only as a folder – no way around this – but since it will be the only folder showing there won’t be any confusion).

what is the maximum size for the thumbnails in video folders - width and height? thanks in advance.

The maximum seems to depend on how many you have.

Some users can use large 1000x1500 jpg images as their thumbs and report no issues… others have thumbs start to not display when they’re larger than about 80kB.

I’ve always resized mine down to 200x300, which usually keeps them between 30 and 60KB, and never had issues with them not showing up.

I don’t see much point in making them any larger, since they don’t display any larger on the WDTV anyways, but then I have ThumbGen making them all for me and it handles the re-sizing.

And for the OP’s question, the stock firmware does just show the stock USB icon for the root, no matter what you do.  I believe if the drive is partitioned, then each partition would show up with a given thumb (partitionname.jpg) in your first level of browsing, but when the partition is the only one on the drive, I don’t think there’s a way to get a different thumb to show up for it.

When the Live caches the thumbs for USB connected drives, it makes them 160*240, so there is probably no reason to make them bigger … I don’t know, if thumbs from shares are cached.


Cocovanna wrote:

… so there is probably no reason to make them bigger …

Unless your WDTV is running third-party firmware and displays the thumbs at 200x300 instead of 160x240 :wink:

RoofingGuy wrote:


Unless your WDTV is running third-party firmware  

… and that’s another forum … :wink:

Can I do thumbs for networked drives? Can’t seem to make it work.

OK, so I have on my drive the following folders:

Theater Movies

Family Movies



On the Theater Movies I have HD avis of all movies, no folders or anything.  So in order to show the Movie Cover (main movie photo thumbnail) i have to create a folder to put the mian movie in and ten create another with folder.jpeg and in here put the movie jpeg?

Please help

TonyE wrote:

So in order to show the Movie Cover (main movie photo thumbnail) i have to create a folder to put the mian movie in and ten create another with folder.jpeg and in here put the movie jpeg?

No, _ moviename _.jpg will be used as the thumb for _ moviename _.avi – you don’t have to have them in separate folders.  But the filenames must exactly match except for the extension.

Got it! I am still transfering my movies from my Iomega SCP to the WD Elements, so once that done I will try. 

What about for Photos?  I have folder for 2001-2002, et, etc, and in each year folder i have individual folders for each event.  Would the Live Plus catch the first photo as thumbnail? like on Windows?


I have a question about showing thumbnails for AVI files - I know they should be named identically, but I have a slightly different issue.

I have the files named correctly I believe, for example:



In the folder with my movies, I see *both* files - each one with the correct image, but I don’t want to see the .jpg file - it’s only in the folder to match the image with the AVI file.  I have several coworkers with WD TV units (not live like mine), and they only see their AVI files with the correct thumbnail displayed.  Why the heck do I see both individual files, and is there any way to *not* display the JPG files separately?

It seems like a not-very-useful feature to have to scroll through all the JPG files until I get to the AVI’s, to browse for the movie I want to play…  I have gone through the different options, and they all seem to display the two distinct files and not just the movie with thumbnail like I’d prefer.

Thanks for any help you can provide!

Coworkers are probably using local USB storage, not network storage. Thumbnails for network shares have never worked right, and doubtful they ever will fix it…

AH.  Thanks, Tony.  That has been driving me nuts, glad to know I’m not crazy.

Now, if only they’d fix it…

Ok, did some tryouts but nothing.  I have for sample

Solitary Man.avi

Solitary Man.jpg

But the Thumb does not show/   Coulkd it be that there is SPACES and the title have to be without spaces?  for sample

Please help.

Given the subject of this thread, are you asking how to name the file so a thumbnail appears on the FOLDER, or on the movie itself?

Your names are correct for the latter case (and spaces don’t matter.)

If you want that thumbnail to appear on the FOLDER for that movie, the jpg has to be INSIDE the folder, and named “folder.jpg”

EXACTLY that;  NOT the name of the folder itself.

Confusing, yeah, I know.  :)

So, you might have

Solitary Man   [ folder]

   - Solitary Man.avi

   - Solitary Man.jpg

   - folder.jpg

inside that folder.

Thanks Tony, I have a big folder named “Theater  Movies” and inside that I have all .avi’s file.  What i did was to download several jpegs of several movies, named them exactly as the avi it self and place them in the same “Theater Movies” folder.  But they don’t show up…

Do I need to make individual folders for each movie?  I though I don’t have to?

On the other hand, I saw one picture on the actual WDTV Live Plus package box, where the guy is looking at his Movie archives in "Preview mode, but has thumbnails of each clip instead of a circular dics and movie clip icon.  How can this be done…?

And yes, very confusing.  Thanks

Ok, So I wanted to comment on this as well, becuase I did have all my pictures of movie posters displaying and then as I add new folders and movies to that main folder they seem not to display the picture for the folder.   Heres how I have them listed. - Most of my pictures for the folders do display, some dont.


|_Family Guy > Family Guy.avi and folder.jpg

|_Ghost > Ghost.avi and folder.jpg

|_ James And The Giant Peach > James And The Giant Peach.avi and folder.jpg

TV Shows

|_Burn Notice


          Season 1   > Burn Notice - 101 - Pilot.avi and folder.jpg

          Season 2  >  Burn Notice - 201 -"Name OF EP.avi and folder.jpg

          Season 3  >  Burn Notice - 301 - “NAME OF EP.avi” and folder.jpg

          Season 4  >  Burn Notice - 301 - “NAME OF EP.avi” and folder.jpg

The TV shows all list that way, and the folders are all displayed   Its the Movies that sometimes dont show the pictures of the movies.   Not sure why that is, and some of the pictures for the movie posters are Huge and they show, but the not so big files dont show.   Previous to there firmware updates I did have all of the Movies and .jpg files in 1 folder with there same names.   I wanted to seperate them all and this worked. But keeping them all the same name didnt work.

This is how I have them and it works. 300+ movies and 30 Tv Series.  I Hope this helps out.


Ok, since I have also the movie trailers, i did a folder for every movie. So inside the main Theater Movie Folder i have for sample:

Takers (Folder)

  • Takers.avi

  • Takers.jpeg

and an empty folder named "folder.jpeg


1- So now when I am in the preview mode, in the preview window, i see a big grey folder and the movie jepeg on the bottom right…not small but not so big.

2- When i switch to List view, I only see the round DVD and the name of the movie. thats it.

3- Isn’t there a way to see the jpegs bigger on preview mode?

I am sorry, but now is a Mission!  Thanks