How do I access "/mnt/HD/HD_a2"?

I am trying to access my Plex logs located at /mnt/HD/HD_a2/plex_conf/Plex Media Server/Logs on my My Cloud Mirror.

How do I go about accessing the folders “under the hood” such as /mnt/?

1 Like

Hopefully an experienced SSH User will be able to assist.

Enable SSH on your NAS box, then use Putty for Windows or VSSH for Mac to ssh to your NAS.

SSH to your NAS box, then do “cd
/mnt/HD/HD_a2/plex_conf/Plex Media Server/Logs”

And to get it off, simplest way would be to copy (cp) it to one of your shares (found under /shares) and then grab it off there by SMB or NFS etc as normal.

Sorry to dig up the old thread guys. I had meant to keep up on this, but then I had some other stuff going on and got away for a bit.

I’ve gotten into the drive through Putty, but I am having trouble changing the directory. Here is what happened when I tried the commands you posted above: http://i.imgur.com/tMm9Sv1.png

Is there something wrong with my Syntax?

Looks like you’re missing a folder somewhere along the line for some reason.

Do it step by step, as follows:

cd /
cd mnt
cd HD
cd HD_a2
cd plex_conf
cd “Plex Media Server”
cd Logs

Note at which step in the file tree it fails (ie which of the directories doesn’t exist). At that level type “ls” (without the quotes) to list the content of the folder you’re currently in. Have a look and see if the folder you’re trying to access is there but maybe under a slightly different name, or if it’s entirely absent.

Note that there’s no / in front of any of the folders in the cd commands (aside from the first one) as / indicates the root folder, and so /HD would be a folder “HD” in the root directory of the disk.

See at what point things go wrong for you and then report that back here (along with a screenshot of the ls command for that folder if you can) and we can see what else we can suggest perhaps.

Cool, looks like using quotes around “Plex Media Server” got me there.

Now that I’ve gotten that far, what command do I need to type in to copy some of the logs either locally to my C drive or elsewhere on the My Cloud where I can access it?

Cool, I used cp “Plex Media Server.log.5” -t /mnt/HD/HD_a2/Public and that seems to have done the job. Is there anything more that I should know or be cautious of?

The spaces in the “Plex Media Server” folder name is what requires the quotes, so that the OS knows to take the whole thing as one, rather than three separate arguments (as you can see from the error message, without the quotes it just tries to cd Plex, and ignores the other two. That’s why commonly underscores ( _ ) are used to replace spaces in such folder/file names, as in HD_a2 and plex_conf in this particular example.

Anyway now you have the file in your public share, you should be able to access it remotely from computers on your network in the normal way.

This kind of SSH access is fairly basic and safe, but there are more dangerous things that can be done using SSH which can brick your MCM (never do apt-get for example, and be extremely careful with moving (mv) and removing (rm) files as you can accidentally lobotomise your MCM if you move/remove the wrong files).

Anyway that doesn’t apply in a simple copy case like this. Glad it’s sorted anyway.

Awesome. Thanks for your help @DarrenHill! Now I’m off to the Plex Forums to get some help with Transcoding!

hi ya i am trying to copy bundles from pc to nas
i have managed to use the above info to log into server but dont know the commands to copy from pc to server could you please help
i have been stuck on this for days
doing my mrs head in because i dont want to give up

im trying to copy from e: to nas this is what i have tried so far could anyone help me with command
root@MyCloudPR2100 root # cd /
root@MyCloudPR2100 / # cd mnt
root@MyCloudPR2100 /mnt # cd HD
root@MyCloudPR2100 HD # cd HD_a2
root@MyCloudPR2100 HD_a2 # cd plex_conf
root@MyCloudPR2100 plex_conf # cd “Plex Media Server”
root@MyCloudPR2100 Plex Media Server # cd Plug-ins
root@MyCloudPR2100 Plug-ins #
root@MyCloudPR2100 Plug-ins # cp E:\plex bundle
cp: cannot stat E:plex': No such file or directory root@MyCloudPR2100 Plug-ins # volume1_Plex_Library_Application Support_Plex Medi a Server_Plug-insE:\plex bundle -sh: volume1_Plex_Library_Application: not found root@MyCloudPR2100 Plug-ins # E:\plex bundle -sh: E:plex: not found root@MyCloudPR2100 Plug-ins # root@MyCloudPR2100 Plug-ins # E:_plex_bundle volume1_Plex_Library_Application Support_Plex Media Server_Plug-ins -sh: E:_plex_bundle: not found root@MyCloudPR2100 Plug-ins # cp E:_plex_bundle cp: missing destination file operand afterE:_plex_bundle’
Try cp --help' for more information. root@MyCloudPR2100 Plug-ins # cp E:\plex bundle cp: cannot statE:plex’: No such file or directory
root@MyCloudPR2100 Plug-ins # cp help
cp: missing destination file operand after help' Trycp --help’ for more information.
root@MyCloudPR2100 Plug-ins # cp --help
Usage: cp [OPTION]… [-T] SOURCE DEST
or: cp [OPTION]… SOURCE… DIRECTORY
or: cp [OPTION]… -t DIRECTORY SOURCE…
Copy SOURCE to DEST, or multiple SOURCE(s) to DIRECTORY.

You can’t do that.

The method I described above is remote access to log into the NAS box, so essentially you’re working on the MCM rather than your computer. The E: drive is on your PC, so it’s basically like you ringing your mum up on the phone and telling her to look at the newspaper that’s on your kitchen table.

What you can maybe do is download a program like WinSCP, which allows file transfer over an SSH connection. That might work for what you want, but the same caveats apply as I mentioned before. I haven’t tried using WinSCP on my MCM as I just use SMB and the shares, but it might work for you.

You could also use the normal SMB shares to transfer your files into a suitable folder on the MCM, and then use SSH to move them around on the MCM itself into the correct place.

Given your comments and attempts made so far, you may want to do some research and read around things a bit first, as Linux-type operating systems (such as the one the MCM uses) are different in their file/folder structure to Windows machines (for example drive letters like E: are not used on Linux). Basically be very careful what you are doing or else you risk damaging or killing your MCM if you screw up the file system.

cheers daz you the man
all sorted pal
you dont know how much it means to me
thank yoi

use WinSCP , ez