Host web site on MyCLoud


I’d like to host a web site on my WdMyCloud, so I followed this tutorial

I’m having trouble to restart apache, the a2ensite command is not found on MyCloud, neither apt-get to install it.
Is there another way to restart apache, or to install packages ?


If you do a search of the My Cloud subforum you’ll find several threads discussing how to install/run a webserver on the My Cloud. Note that the single bay My Cloud units are not really designed to host a full fledged website. Note: Many if not most of the links below deal with the v3.x/v4.x firmware My Cloud. My Cloud’s running v2.x firmware is different and the directions below may not work with v2.x firmware.

Ok I solved this, now another problem is showing up : there isn’t mySql installed on MyCloud. On the dashboard I tried going in Applications to add phpMyAdmin (I guess it install mySql too), but I have no “add application” button. All I can see is “http downloads” and “safepoint migration”. How do I install mySql and phpMyAdmin on this ?


Firstly, I think you need to go and research the product you have just bought.

Secondly, you said you have read all them topics bennor suggested?! Looks to me like you haven’t going by your last reply.

And lastly, The single bay WD my cloud is not capable, is not capable, of the what you are trying to achieve.


Are you saying there’s absolutely no way to install mySql on the single bay WD MyCloud ?

Officially? Yes there is no way to officially add MySQL to the single bay My Cloud. You are trying to perform an action for which the My Cloud was not designed for.

Unofficially? Did you read the links I posted above? In particular the thread “Repository with software worked on v4 firmware”? Have you done a subforum search for MySQL? There are several threads that discuss trying to install or use MySQL on the My Cloud (most likely the v3.x/v4.x single bay My Cloud units).

The single bay My Cloud units (both the v3.x/v4.x and v2.x firmware versions) are low end units with low powered processors/RAM that are not capable of effectively running certain unofficial, user installed, features/third party apps. Currently the v2.x firmware single bay My Cloud, which by your previous post, you appear to have does not currently officially support adding additional modules beyond those two listed. More expensive My Cloud units do support adding additional third party apps. For example see the following link for the third party apps the My Cloud Mirror officially supports: