Hitachi External USB 3.0 3TB HDD (Touro Desk Pro) Unrecognized in Windows 10


#1

Hi everyone,

Please help me solve the problem with USB 3.0 3TB HDD unrecognized in Windows 10. Your responses/suggestions are appreciated.

Core Issue

My external 3TB USB 3.0 Hitachi Desk Pro is recognized by Windows 10 device manager but is not recognized by Disk Management. To be more precise, it is unknown in Disk Management thereby incapable of being initialized. See image below.

Background Info

I have had this issue since I first upgraded from Windows 7 to Windows 8 and now on the latest Windows 10 (v.1703) (OS Build 15063.138). It works flawlessly on Windows 7, Linux and on Apple OSX.

What I have Learned & Tried

I have pretty much spent a lot of time gathering information about this, trying everything to find a solution. I have tired Microsoft hardware troubleshoot guides that Microsoft online support recommends, which have been completely ineffective.

I have tested the HDD on three different computers: two laptops with Windows 7, 8/8.1 & 10, Linux GParted and on one Apple MacBook Pro OSX with brand new USB3 cables plugged directly into the computers. The HDD works perfectly on the computers except with Windows 8/8.1 & 10 OS installed.

The closest thing to a solution that I have tried has been to install modified driver by Fernando (win-raid.com). The drivers actually work making the HDD recognizable. Even though many people have had success with Fernando’s drivers, they may not be perfect. After a few minutes after installing Fernando’s drivers, the HDD begins to disconnect when I attempt to use it. It gets worse whenever I unplug and plug it back in or restart the computer. From there onward, as I attempt to copy a file etc., after a second or more later, it disconnects then reconnects, interrupting the read/write process.

There many threads online that have somewhat targeted the issue on the power saving functions implemented in Windows 8/10. Even though I have exhausted pretty much every registry tweak I could find on USB power management, this has not solved the problem for my Hitachi Touro Desk Pro nevertheless it still might be connected to core issue in Windows 8/10.

Fernando’s team have accomplished something that Microsoft’s team hasn’t been able to fix since the launch of Windows 8. This is absolutely unacceptable and unsatisfactory product/customer support. Try Fernando’s Modified Drivers here: http://www.win-raid.com/t834f25-USB-Drivers-original-and-modded.html

Many people have bought additional PCI cards/USB Hubs and, or have reverted back to Windows XP/7, or believe that their Touro Desk Pro is faulty.

Suggestions

Does anyone out there have any suggestions? Should an online petition be set up to get Microsoft and Hitachi to fix this problem now?

I have made a screen capture video of exactly what happens here:
Hitachi Touro Desk Pro (3TB) Unrecognized in Windows 10


#2

I have a similar problem with my HGST Touro Desk Pro 4TB. Worked fine with Windows 7 and now is not even recognized under Windows 10 Pro, 64-bit,16 GB Main Memory. I’ve had two passes with tech support person Domingo and he tells me to test it with the WDC tool. Can’t test it if the PC can’t see it.


#3

Separate, but related question: There are several reports with similar problems and, as far as I saw, none of them have WDC solution responses.
…
My question is: Why is WDC not responding to our problems? Can we return the devices after we copy the content using Windows 7?


#4

Have 2TB pro. Booted WIN10 1703 with Touro unattached. Admin login. Attached USB and it shows. In Diskmanager change driveletter (i.e. H:) and close out. Shut down and reboot. On my Intel NUC its there, also for other (normal) user. Regards and good luck, JanB. PS the drive letter change comes from tips regarding other HDD problems.


#5

Just one more solution
I have copied drivers from old Windows and overwrite them into Windows 10. That works
I make it here: https://thoaimedia.com/how-to-fix-hitachi-external-usb-3-0-3tb-hdd-touro-desk-pro-unrecognized-in-windows-10/


#6

@anhthoai Thank you. Finally, a solution that works!