Hints for debugging DLNA problem


This is on a MyBook Live 3TB 02.42.02-012 with no modifications. Stock f/w

My music collection contains just over 10000 mp3 files.

The DLNA Server crashes when I try to browse my music collection via DLNA.

dms_smm process segmentation faults when i browse the music collection via  “Music\Artist Index” and “Music\Album/Artist”

It crashes using multiple devices, e.g the same thing happens when I browse from my LG TV, and by my Windows 8 laptop.

I have tried removing and rebuilding the database.

Does anyone have any hints on how I can debug this further. The dms_smm program doesnt seem to have any options for making the output more verbose.

I assume there is a file in my music collection that the dms_smm process doesnt like.

Any suggestions greatly appreciated.

Graham Wharton

P.S. Looking for solutions other than Remove my music collection and add files until problem happens. (as thats what I am currently doing, but with >10k files that might take a while to find it)

Hi, have you tried going back to the Twonky server to see if you get better results? Check the link below for the steps. 


I’m running MyBookLive 02.42.02-012 : Core F/W and according to the link you posted (unless ive misread the article), the Twonky patches will not work.

I also cant find a link to downgrade to a version of the firmware that has the twonky version preinstalled.

Hi again, the patch works with firmware version 02.41.05-034 or later. 


The webpage you pointed me at states that “Go to the Media tab in the My Book Live’s dashboard, and if it displays like the image below, then the patches will not work.”

Mine does look like the image below and they dont work. I tried downloading and applying the patch and it responds with the error “31101 - Invalid firmware package”

WD Media Server segfaults on a regular basis when browsing my music catalogue, and also sits at 100% CPU when rescanning my catalogue every 15 mins or so. This takes about 5 minutes, during which time streaming HD content is unusable due to jitter.

Ive given up with the WD media server and Twonky and installed TVMobili as a trial. All seems well sofar.

See if the following link solves your problem. 

Error: 31101 - ‘Invalid firmware package’ occurs when upgrading a My Book Live firmware (FW 02.41.05-034 or higher) via the Twonky or Access patch

I did see that article, and I did confirm that my file is named the same as the download.

My file is named “Twonky5MediaServerPatch.deb”

The download link is " http://download.wdc.com/nas/Twonky5MediaServerPatch.deb"

I still get the 31101 error.

Anyway, dont worry about it. Ive purchased TVMobili and installed onto the mybooklive and that is perfect. Configured just how I want it, streams HD contents just fine, very low CPU usage, especially when streaming HD and indexes my entire music collection without crashing :slight_smile: