Hidden ._ files on hard drive which only appear when connected to a Samsung TV


I recently copied all of my ripped movies (DVD’s) from my iMac to an  WD Elements external hard drive. I then connected the hard drive to my Samsung TV. As all of my files were ripped to  .m4v  format my TV wouldn’t recognise them. A simple fix, which worked, was to use  NameChanger  to simply change the file extension of all my movies to  .mp4. My TV recognises and plays the files fine BUT I now have some duplicate files which start with  ._  before the name, for example: ( ._GOODFELLAS.mp4 ). These duplicate files do not play and annoyingly appear at the top of the list. When I go back and connect the hard drive to my iMac to try and delete these ._ files, they do not appear. I have already tried showing hidden files option on my iMac but they still do not appear. I have also erased the hard drive and copied all my files back but the ._ files still appear when connected to my Samsung TV.

Any ideas on how to find and delete these pointless duplicate files from my hard drive?

Thanks in advance.

Hi and welcome to the WD community

This could be created by TV itself when it plays the files, but just to check do the ._ files appear always or is it only when you play the files on the TV?

I also have come across this problem when copying photos from my iMac to a (FAT32) memory stick and I can’t view the photos on my Samsung TV. The '._" does NOT appear when listing the files on my iMac, nor do they appear when I view the files on a PC. However, when on the PC, I copied the files to a NEW directory, and then the files in the new directory did not have the ‘._’ prefix when viewed on my Samsung TV, and so I could view the photos OK!

This is a workaround, but it’s a bit of long winded way to overcome the problem (and you need to have a PC)!

Is there an iMac solution for this?


I have the same problem, I can see and view on my smart Samsung when accessing my NAS drive through the TV 6 films, but when I access my NAS via the WD software on my laptop the 6 films do not appear anywhere in any folders, they seem to be hidden, how do I get at them to delete them.
I have telephoned WD help line and asked them, he told me to back up all my files and format my drive back to factory settings and reinstall any files I need.
I would like to see and remove them, not format my drive.
How do I do it


I found your questions while searching for the same problem. Guess what? If you’re using a Mac here is the answer: https://www.youtube.com/watch?v=Vbnthx7-SR4