Help with my book essential 1 tb


I’ve bought a few months ago this my book essential 1 TB. I have windows 7.

About a week ago i shift+deleted all of my music and movies by mistake in another hard disk. So, i decided to find a program that might undelete those files for me. I found a program called “smart undelete”, and i started undeleting my ~300gb files from that disk to my external my book essential. I was undeleting everything and then i was trying to see if the files worked, and the ones i tested worked just fine.

Then about 20 minutes after i completed the undelete i tried to see the files of my external hard disk and i got a message that explorer was not responding, then the computer got stuck, and couldn’t restart windows successfully. After a few resets windows started successfully but without my 1 TB external hard disk, it showed up as “wd ses device usb device” but didn’t work when i installed the drivers, i unplugged my hard disk and took it to a laptop and didn’t work there either.

Anyway, i left the hard disk offline for a few days, and i decided to give it a try again today. I connected it to my pc while windows were allready running. The result was that it recognised my Hard Disk at first, and i could see in some of the directories, but then when i tried to open some of the directories it showed the names of the files but like it didn’t know their extention and got stuck, and i had to reset my computer. So, now if i start the windows with the device plugged in it doesn’t start the windows at all, while if i start it and then i plug in the hard disk i get a repeat of what i describe above, i can view the contents of the directories but it get’s stuck after a little while.

Also, i’ve tried plugging in my hard disk and then using “Test disk” and it got stuck at “please wait”, couldn’t even show me the list of the drives.

I want the data that’s in there can i do something about that?

If not i’m a little worried that if i take it to the local WD dealership they’ll simply try to format it and if that fails they’ll replace it without ever trying to recover the data since it will surely be faster/easier for them. :S

I’m even willing to lose the guarantee by opening the **bleep** thing if there’s a chance to save the data.

Thanks in advance for any answer.

don’t waste your warranty.  you have file corruption.   any files that are corrupted won’t be recoverable anyway.  get as much off as you can, then delete the partition, repartition and format the drive.  sorry, but it happens…