Help with Logitech Media Server

I’ve had nothing but problems since migrating from running LMS on a ReadyNAS 104 to my EX4100, so I’m hoping someone here can help. The first issue I had was with my playlists seeming to disappear all on their own. I did some searching and found the answer was to move the playlist to the same directory as the music folder, and that worked. However the biggest headache I have is that LMS will sometimes just up and stop playing for no reason. Most of the time when that happens, I also have trouble accessing the LMS GUI via the web (it’s either unresponsive or very slow loading the page). Usually it stops after a song has finished, and if enough time has passed (like if it stopped playing while I was away), I can simply click the play button and get things going again. LMS will stop multiple times a day and it’s really getting aggravating.

My collection is modest, just over 2400 mp3’s, stored in groups of 500, so 5 folders. I run LMS on the EX4100 and and connect using SqueezePlay on 3 PC’s. I also connect 2 Android devices, but LMS stops whether they’re being used or not. I also store screensaver images on the EX4100, and the same 3 PC’s use those images all at the same time. LMS is V7.7.2 - 33893 and firmware on the EX4100 is 2.31.149. My entire Gigabit network is hard wired, the EX4100 connects to a DLink 16 port switch that’s connected to a Netgear router. Please, does anyone have any suggestions on getting this resolved?
Here’s an example of what I see when LMS stops working. The song timer keeps running, and the playlist is blank. This is the forth time in just 6 hours LMS has stopped, and I currently have just one device streaming (my phone), so I don’t think it’s a bandwidth issue.


Well I’m beginning to believe this is an issue either with the WD hardware, or the version of LMS that it comes with. I copied my library over to my PR4100 running the same version of LMS, and within 8 hours it had stopped. I decided to fire my ReadyNAS 104 back up running it’s version on LMS (7.9.2 - 1550612824) and it’s been going fine for over 12 hours (knocks on wood). I’m willing to install the latest version of LMS on either of the WD’s, but I understand it involves changing the version of Docker. Is there a good write up somewhere for doing that?