Help with bricked MBLD

Hello everyone

I did a very stupid thing and upgraded Debian installed on the device. After reboot I completely lost the access to it: no ssh, no Web UI,… I can ping it and the green light is up, so OS is up. I tried reset button but all it did was setting IP address to automatic.

My main concern is how to rescue my data. If there was just one disk I would just plug it into my motherboard and make the backup, but the problem is that disks are paired into RAID 0 configuration. I don’t have experience with RAID arrays, so any advice on how to rescue my data would be highly appreciated.

Thanks in advance

If you are concerned about your data I recommend you to contact a professional data recovery service, since recovering data from a RAID array is a complex process.

Apparently, everything went well at the end.
Here is how I did it in case someone gets in similar situation.
I hooked HDDs on my MB and booted Fedora Linux. Over several days I was trying to figure out how to assemble RAID, but no success. fdisk reported 2 new drives both with 4(?) partitions, and 2 md devices /dev/md126 and /dev/md127. I could not just mount mds, and when I had no success using mdadm --assemble either. So, I tried mounting partitions and fount out that first partition on both disks are identical, 2GB big, and have Linux system on them. I assumed they are part of the RAID1 configuration, and simply download the firmware, extracted *.img file from *.deb, and dump it on those partitions:

dd if=img_file_path of=/dev/sdc1 <-- letters 'c' and 'd' are specific to my system, they might be different for yours
dd if=img_file_path of=/dev/sdd1

When I put HDDs back into MyBook casing, it was back to life.

Also, there is a Windows program called DiskInternals Linux Reader that will let you access your data and safely backup it before you try something like this.
hope this helps