Help with a 2TB WD Elements Portable drive

Hello all,

I have a 2TB WD Elements Portable drive that I am using on a MacBook Pro. It has worked great up until recently.

Recently, I was making a bunch of separate USB hard drives (not from WD) with the name “Blast Dance” for a project I was working on, this was being done entirely separate from my WD Hard Drive, and It had not been plugged into my computer until this morning.

This morning when I plugged my WD hard drive in, It was reading it as if I had formatted the drive and wiped it clean, with the name of the project that I was working on in its place. I know this is not the case as I kept the USB Drives and my WD drive all separate through the entire process, plus I am using a USB-C cable for my hard drive, where as the other flash drives I used were just USB 2.0.

I also tried using my other WD drive (for other projects) on my computer and it works fine.

I tried the WD drive that isn’t working properly on another computer and same result, which leads me to believe that there is some sort of information disconnect between my drive and my computer. This is just my assumption though, I don’t know if this is a common or if anyone has experienced an issue like this. Because I know for a fact that I did not Format this Drive.

I say all that to say that hopefully you guys can give me some answers, if I need to ship my drive offl for a recovery/restoration process I totally will, but I wanted to make sure there wasn’t an alternative that I should attempt first. Thanks for the help!

Hi @GajeGarrett,

You should try contacting WD’s Technical Support about this for live assistance and troubleshooting:

To Contact WD for Technical Support