Help with 1TB External Mybook (PLEASE) not appearing in win10

I need help please… I have a 1TB External MyBook and when i plug it in it lights up in front and stays BLUE solid light… I plug it into the computer USB and it doesn’t detect it… I also tried different USB cable and same thing… The win10 computer doesn’t detect it at all…

Can someone tell me what I should do…

Hi
I’m having problems with 6TB one I’m working with tech support at moment mine does it everyday went this morning 12hrs before that 24hrs before that, I leave usb plugged in computer running turn off power to drive leave 30 secs then turn on again, and we’re up and running again
but a starting point fix to try is uninstall disk driver and USB controllers get them updated to latest versions
and that was a Microsoft Tech answer to same problem people’s My Books disappearing
(may not work I’ve done it on mine a few time last couple of weeks)

Give this a shot.
It may or may not work depending on root cause:

  • Run devmgmt.msc or Control Panel -> Device Manager
  • Expand USB Serial Bus Controllers, right-click on USB Root Hub and choose Properties
  • Select the Power Management tab
  • Uncheck “Allow the computer to turn off this device to save power” and click OK to save the changes and repeat for all
    remaining USB Hubs
  • Restart the computer

If the device is still not recognized,
undo the changes by Checking the "Allow the computer to turn off this
device to save power" for all USB hubs.

·

  • Restart the computer after saving the changes.