Hi! i have a problem with the hard disk i just bought… it’s a 2T sized, running on a winXp SP2 machine, partitioned about half and half, used mostly for storage. problem is, i often get I/O errors when writing on it (such as in some downloads). sadly, no other details are provided along with this message. what do i do? is it a hardware problem? a faulty disk? is it about to explode??? :wink: thank you all in advance for your help

Hi get a trial copy of Hard Disk Sentinel install it and start it. It will give you a report on the hard drive right away. Next Choose the Smart data tab take a screen shot of it and upload it here.  . Make sure you get the complete smart data in the screen shot.

hi hammey!

thanx for your reply! i did as you said, and according to HDS, everything looks fine…

i was wondering if it could be a motherboard issue, for it doesn’t support sata3.

anyway, here’s the screenshot

hope it helps, thx again!

Hi I can not see the screen shot. If the hard drive serial number is in the screen shot it wont show. Otherwise a mod will sort it. What Motherboard is it.


motherboard is gigabyte GA ma790x DS4

hd serial n. should be WD-[Deleted], model ID: WDC WD20EZRX-00D8PB0

i noticed just now i wrote a wrong title for the topic, sorry! i picked the other hd’s name :wink:

i’ll try again and insert a better screenshot

i’m using the insert/edit image button… i wonder why the screenshot doesn’t show… anyway, thx!!

Hi the Ultra ATA CRC Error Count looks strange to me it should be like 200  200 then a bunch of 0000018. 18 being the number of errors I have no idea why yours is 200 1 either way this represents a data error either from a poor power supply or a bad sata cable. It is a Amd chipset so all you can do is make sure the chipset driver’s are up to date and also your system bios but a sata 3 drive should work fine on any sata 2 controller.

Thanx hammey!!! I tried and replace the sata cable, and so far it seems that it’s working. no errors, since this morning… i really hope it turns out to be this easy… and just for once i hope i was the dumb one :wink: if everything goes smoothly in the next couple of days, i’ll consider it solved. deep down i knew that WD would never betray me!

it works! three days without an error… thank you hammey! ty ty ty

Hi great glad all is well.