HELP: WD SmartWare installation problem

I just bought a 500 Gb My Passport Essential USB 3.0 Hard Drive, I manually installed the WD Smartware software I found inside the Hard Drive folders, but it doesn’t seems to end the installation and hungs on 25 seconds to the end everytime I try to install it. I installed it on other 2 different PCs and it worked.

I have Windows Vista on this PC.

At first: why I need to find the setup files manually? It doesn’t auto-start, and that’s a big problem for less skilled people who don’t know how to find the drivers manually, don’t you think?

How to solve my problem? I can see the Hard Disk folders, so I can use it, but I want to install the drivers correctly and avoid all that Windows popups about the installation fail.

1 Like

The only driver you would need to install is this one SES device

here are instructions on how to install it.

click on the link!!&p_li=&p_topview=1

Hi I have just purchased My Passport Essential WDBAY5000a and I am having major problems trying to install the Smartware installation.

Everytime I link the drive it will not let me load the SES driver and detects it as a new hardware everytime - I have tried going into the specific location and select drive E to download this manually and this has not worked.

I am also unable to download the Smartware software - every time it gets to 1/3 of the progress bar it shuts down and will not upload - i have looked at the forum, uploaded the, turned off antivirus and firewall and this has made no difference.

Can you please help ???

I am mega struggling :slight_smile:


What exact error message are you receiving?

Also make sure you are not using a usb hub or docking station.

If a desktop make sure its connected to the back of the pc.

now if the ses is not install the computer will not recognize the drive.

if you want the smart ware up date here is the link

Yesterday I tried to install the default driver for the last time, before following your instruction. Well, after 20 minutes of pending it worked, don’t ask me why because I really don’t know. :smiley:

Now the WD SmartWare is running and seems to work good. In case of problems, I will install the driver you suggested.

Thanks for your help.

Hi there

I don’t seem to get any error messages??

Just if I am trying to load the software the time bar goes along for a while then shuts itself down.

I still cannot load the drivers however the computer does recognise it as a new piece of hardware when I plug it in however then states the this is a fault.

I am not sure what I am doing wrong??

It has now installed - didn’t do anything different!

Thank you for your help :slight_smile:

Did you get a Windows update?  Because the SES driver comes in later updates of Windows.  Make sure you have all your latest updates for your motherboard drivers as well as for Windows.