Help. WD Gold no response in power on

A WD Gold 4TB CMR internal driver installed with Windows 11.

Suddenly the valumes of this disk were disappered in Windows. Restart the computer and the disk didn’t detected in BIOS.

The body of the disk was cold after turning off my desktop and removed the disk from it.

Reconnect power cable and SATA Cable. Still doesn’t work.

Connected the disk with USB-SATA convertor(with 12V external power supplier). The motor and the heads of disk didn’t have any responses.

Try to disassembled the disk, there were 2 fireware chips on the PCB. Seems one of the chip is used for backup.

So, the QUESTION is: is this the trouble was caused by fireware chip failed? And is there any way to fix it by the backup fireware chip on the PCB?

What is the part number of the PCB (0Bnnnnn or 0Annnnn)?

Can you upload a detailed photo of the PCB? Can you get hold of a cheap multimeter?

Thanks for your kindly reply.

001-0B41785. Perhaps it is the part number we are looking for.

Measure the resistances of the two TVS diodes (Y4 and SUA) and two fuses (“S”) near the SATA power connector.

Trying, :slight_smile:

Measured. The resistances of Y4 and SUA both is about 550Ω. Both fuses working normally.

Seems the power circult is OK.

Any ideas?

What is the resistances values of Y4 and SUA should be?

A replace PCB(same model) is on the way and will be arrived in few hours late. We intend to transfer the old fireware chips to this replace PCB for trying fix it.

Is there any possible that the trouble was caused by fireware failed? that is aweful if it is true.

Your diode readings are OK. The fuses should measure 0.0 ohms.

There are two 8-pin ICs at the top left of the PCB. These are electronic fuses. You should measure +5V and +12V at the input and output capacitors of each fuse.

You would be unlucky if your “ROM” chips had corrupt firmware. In fact, I have repaired several such cases. If you can dump the contents of these ICs (1.8V Vcc), I have written a tool to verify the checksums.

There are two 8-pin ICs at the top left of the PCB. These are electronic fuses. You should measure +5V and +12V at the input and output capacitors of each fuse

Thanks, I will try it.

I had asked WD for answer of why there are 2 rom chips, and is it one of it used for backup. Their reply was just better than nothing.

This is the first time that I run into "Dual Rom Chips"designs on HDD PCB. Why they choose this sort of sulotions? Is there any possible that WD stored a freash copy in one of ROM chips?

If the things just like what I just mentioned. Perhaps we can fix it by “Switching to the correct ROM”.

The only way is dunmping fireware from ROM chips, if transfering the old rom chips to replace PCB doesn’t work. :worried:

I have seen WD PCBs with 7 ROMs. The other 6 had nothing in them, or at least nothing that I could make sense of. I suspect that they are used to cache write data in the event of sudden power loss.

Sometimes there are backups within the same ROM, probably intended for recovery from a failed firmware update. You must not damage these ROMs as they contain unique calibration data (“adaptives”). Nowadays the HDD manufacturers have placed unique encryption keys in the MCU. If your PCB is one of these, a ROM transfer to a donor PCB will fail.

If you can provide a detailed photo of your PCB, I will try to identify the test points for the onboard supply voltages.

BTW, yours is a rebranded HGST model with native HGST firmware. It is not yet supported by professional data recovery tools.

Seems the heads have been damaged.

The disk was detected, and the informations about the disk were shown in the Windows.Also the motor can spin and the head move now after replaced a component since it’s resistances value significantly lower than same component on replacing PCB.

But the disk status is RAW and didn’t have any Valume were shown in the Windows. Also, sector checking speeding was very slow.

We doubt that the heads were damaged during the component was failed. That is so weird. The protection circuit is OK,but function circuit has been damaged by component fail.

Which component?

Can you show us the SMART report with a tool such as CrystalDiskInfo?

Can you show us the contents of sector 0 with a tool such as DMDE or HxD? This will tell us if hardware encryption is involved (if you swapped PCBs).

Sorry for the late reply.

The disk has been sent for Data Recovery in last weekend. Perhaps will be back in few days late.

Not sure which componet. Because I don’t have heating guns and just let the Data Recovery shop help me to check it.

It’s true that the motor and heads started to work after replaceing that component.

Also, checked the disk with Disk Genius, No Valumes and MBR/GPT informations were shown.

I didn’t pay attention to the SMART. Not sure they will reassemble the disk again or not. According to the WD’s instructions for services. I have to send back the Original Devices and Not allowed to change any parts on it.

So, If I got the original disk in late days. I will try your ways to get the information about the SMART and others.

Thanks for your kindly help again. :slight_smile:

Please make sure that the DR shop returns your original PCB. This may be essential for data recovery, even if it is faulty.

I got the disk yesterday and the disk has been sent to WD for services now.

Disassembled the PCB from disk. 2 Capacitances of motor and Heads drive circuit were damaged.

The motor and heads can moves now, but no data can be readed from disk.

I guess the heads or amplification curcuits of heads which local in the body were damaged by short-circuit current. That is why the disk status is RAW and sector scanning failed.

What do you mean? AFAIK, WD does not do data recovery. :-?

BTW, those are 20V polymer capacitors. One is tantalum, the other is aluminium.

Conductive Polymer Tantalum Solid Capacitors, TDC series:

Conductive Polymer Aluminum Electrolytic Capacitors, HX series:

They would be used by the spindle motor or voice coil circuits, I would think, in which case I can’t see how this would impact the read/write side of the electronics. If you can show us sector 0 as I previously requested, we could immediately confirm whether you are now facing an encryption issue.

Thanks for the feedback, BTW.

The WD’s offical data recovery company of China is located in HongKong, and we are blocked to access it’s website. I have no choice but to let the other Data Recovery shop help me to fix it.

We measured the resistance of those capacitors, both are significantly low.

So, we guess those capacitors were breakdown and caused the short-cut. The short-cut current may damaged the other components like amplification circuits or the heads drive component in the body etc.Also actived the protective action. As the words of Data recovery shop, there was strange noise of heads during the moment of HDD power on.

BTW. according to the feedbacks of Data recovery shop, there is a copy of firmware stored on the disk. Seems the MCU will compare the firmware stored in the disk and ROM chips. 2 firmwares must exactly the same and it is the key step for booting HDD. So, that is no way to finish this operation since the circuits are damaged and the data on the disk cann’t be readed. Perhaps WD wanna protects their firmwares by this mechanism.

I was rushed to resotre my system and intend to build a RAID 1 after a normal-function HDD return to me. So I sent the disk to WD immediately after I prepared the documents which were required. My work has being disrupted by it. Hard to get the data on sector 0 for making sure what I ran into.

Greatful thanks for your help all along :slight_smile: