Help Wanted!

Hello there, I am trying to do something, though it seems as if it cant be done…well I cant seem to do it anyway.

I want a user and call the user - Stephanie

I want to Stephanie to Access a share - My Music

but I dont want Stephanie to have access or see any other share than - My Music

Is this Poosible?

many thanks for any help

Yes. Go to your my cloud settings: http://wdmycloud

Edit the ‘Users’ and ‘Shares’ sections.

Everyone will have access to the Public share, unless you disable it. Also under ‘Shares’ section.

I have tried this but it does not work, I always have Public access on everyones account.

Turn off Public sharing of all shares.

Add share “My music” and set permission read for your account.

Restart the device if you want, to make sure the settings have been stored.

Thanks for your help, however I cant turn of public sharing on the Public share as it is greyed out!

Sorry, I meant to say off!

Personal opinion the public share is a bad idea that we are stuck with, my opinion is don’t use it for anything. This won’t keep stephanie from placing files int the public share but will keep her out of things you don’t want her in

there are behind the scenes ways to disable this but any FW upgrade or restore will reset it so it is not worth it in my opinion

Check out the Help (?) information provided in the Dashboard. See image below.

As mentioned in a prior post do not place anything in the Public Share that you do not want anyone else to see.

You may want to check out the User Manual too.

Posted by,
cat0w (USA)

Thank you for your reply, But I have read the manual. The Problem that I am getting is that “Public” is greyed out and I cant do anything to change it!


Yes, the Public share is, well, public, but by default. You cannot change the access rights to it.

Thats what I thought, however othersd have been able to do this… So why can some users do this, and not others?

I don’t remember the trick exactly, YOu’d have to search the forum. I think you need to change the name of the share, then you can change the access right, and change the name back or something like this.

To disable Public share:

Login to your Mycloud http://wdmycloud

Navigate to “Shares”

Click on “Public”

If the Public sharing is greyed out, click on “Share name” and try to rename the Public share to for instance Public1.

The browser will return an error message telling you you cant rename it. Now the Public share button should be blue/not greyed out anymore… Works for me anyway. Latest FW…

Good luck

Richie wrote:

Thats what I thought, however othersd have been able to do this… So why can some users do this, and not others?

Thanks fella, that sorted it! many many thanks!