HELP: NFS Shares not playing on WDTV LIve SMP

I’ve got a central storage server in my home running OpenIndiana/napp-it (ZFS) -  The ZFS folder (datatstore/media) is shared as an NFS share with i believe the correct rw,root=@ privliages.  I am able to connect and browse my files on the WDTV however when I click on play, it sits as if it is trying to load.

I am almost certain its not a permissions issue, as I am able to mount the same NFS share inside osx and read/write from it.

I googled, and found an identical issue however I don’t know how to apply this “fix” as I am not running windows;

that fix will not work on the SMP, since it was WDLXTV specific

and while WDLXTV is now available for the SMP, net.mounts is not confirmed working yet

other items you should look at

NIC settings, enable flow control, disable jumbo frames

once net.mounts is working, TCP will help, but currently no way to set that on this device

I know of at least 1 person, who had to use a different NIC, i.e. hardware problem with the NIC

Thanks for the reply, but still no luck…

What I don’t understand is that I can mount the NFS inside two different computers - one OSX and the other Win7 - and read/write to them with absolutely no issues.  I know its not a hardware issue because the two computers above are connected to the same network.

Inside my home I run an HP 1810-24G switch with an Asus RT-N66U router.  I believe this is a permissions error of some sort… ughh cant seem to figure it out.

I would still check permissions.  Since it’s NFS, the CLIENT uses its OWN UID/GID, so results can be different for the two other devices.

Just try setting a few files to bits 777 just to see.