Help...my usb cord broke the slot


#1

Hi l was setting up my book 1TB (changing it over from my notebook pc to my desktop) and it fell off my coffee table and landed on the corded plug into the back (my mistake my jacket caught it as l was plugged it into the USB port in the desktop pc)…is there any way l can get the plug slot fixed on my book as it has alot of important school work and stuff on the HD.  Any advice would be very greatful…thanks


#2

Weird… same thing just happened to me. Anything to do about this?


#3

My slot broke away from the circuit board. I called WD tech support and they advised me to send it to a data recovery firm (costs $850) to recover my data. I phoned tech support back and they advised I could install the drive as an internal drive in my PC. So I did that and now I can’t access my data. 4 years of work lost over a bad design on the USB port and some tech’s erroneous advice.

Hopefully I can get some help on here on how to access my drive and data. If I can get to me data I am going to recover it and FORMAT the WD internal drive and start anew. Oddly, almost everyone I have talked to has said to format the drives before even using them.

Mad@WD!


#4

I don’t see anything wrong with the tech’s advice. The usual recommended procedure when an external drive is giving problems is to connect it directly to your motherboard.

Does BIOS detect your drive? Can you hear it spin up, or trying to spin up? Any buzzing or vibration?

Can you see the drive in Device Manager? Disk Management?


#5

the drive works as an internal, but I cannot access my data. the drive, after initialization, is listed as Online and Unallocated.

The WD SmartWare software won’t let me access the hardrive when it is internal.

I tried reconnecting the USB circuit board and fidgetting the plug around to make a connection but that didn’t work.

I believe what I need is software that will recover the data or the MBR for the harddrive.

I am quite fed up with WD’s lack of concern and failure to support this obvious design defect. I have searched teh web for this issue and found literally thousands of people complaining of the same issue of the USB port coming loose from teh circuit board. Two small soldier spots and some glue is all that holds the port on and then you stick a four foot cable with a two inch connecter on the end that acts like a leverage bar to break your port loose.

It wouldn’t be bad if WD would sell a replacement board or offer to replace the board if the product was sent in. But WD’s only solution is to replace the hard drive at no cost and forget out our data. Data recovery services is $850 to recover the data. That is a bit insane.

I am thinking of a class action suit pushing on the design defect, lack of support, and fraud for selling a prouct and warranty services that are clearly not what is advertised.

Now, help me find a fix for this or I will pull my last 5 hairs out.

Thanks.

Craig-

[deleted for privacy]


#6

Sorry, I forgot about SmartWare.

Can you get some junior tech at your local TV/AV repair shop to resolder your USB connector?

Did you password protect your drive? If not, then I would expect that your partition will be visible to a disc editor.

Can you see your partition with Partition Find and Mount?
http://findandmount.com/

Do not allow any data recovery software, or Microsoft’s disc utilities, to write to your drive. You can use HxD to view your drive in read-only mode.

HxD - Freeware Hex Editor and Disk Editor:
http://mh-nexus.de/en/hxd/


#7

FindAndMount did not find any partitions.

HxD found some material but it says OS is missing.

Any suggestions?

Craig


#8

this is what I could cut and paste:

Invalid partition table.Error loading operating system.Missing operating system


#9

looking at the drive in HxD it shows some data at Sector 0 which states the OS is missing, no partition, etc.   

The next data starts at Sector 2041.

Can I set a new partition on this drive and not affect my data?

What about installing an OS for the drive?

I really appreciate your help on this. Many KUDOS for getting me this far.

Craig-


#10

Please don’t write to your drive. If you wish to experiment, clone the drive and write to the clone.

Sector 0 appears to be a Master Boot Record (MBR). Does it look like the following?

An Examination of the Windows 2000 ( NT5.0 ) and Windows XP ( NT5.1 ) MBR:
http://mirror.href.com/thestarman/asm/mbr/Win2kmbr.htm

If so, then the partition table will begin at offset 01BE (near the end). Can you export sector 0 to a text file?


#11

Not sure about exporting but I can copy and paste. Will that help?

If there is a process for exporting sectors to a file please let me know.


#12

I looked at the link you sent me. The third image down the page looks almost exactly like mine does in HxD. Here it is copied and pasted:

3ÀŽÐ¼.|ûP.P.ü¾.|¿…PW¹å.ó¤Ë½¾.±.8n.|.u.ƒÅ.âôÍ.‹õƒÆ.It.8,tö µ.´.‹ð¬<.tü»…´.Í.ëòˆN.èF.s*þF.€~…t.€~…t. ¶.uÒ€F…ƒF…ƒV…è!.s. ¶.ë¼.>þ}Uªt.€~…tÈ ·.ë©‹ü.W‹õË¿…ŠV.´.Í.r#ŠÁ$?˜ŠÞŠüC÷ã‹Ñ†Ö±.ÒîB÷â9V.w#r.9F.s.¸…».|‹N.‹V.Í.sQOtN2äŠV.Í.ëäŠV.»ªU´AÍ.r6.ûUªu0öÁ.t+aj.j.ÿv.ÿv.j.h.|j.j.´B‹ôÍ.aas.Ot.2äŠV.Í.ëÖaùÃInvalid partition table.Error loading operating system.Missing operating system…

Does that help?


#13

I can read hexadecimal, but not hieroglyphics. :slight_smile:

Go to Edit -> Select block.

Select the hex radio button and then enter Start offset = 0, Length = 200.

Go to File -> Export -> Editor view, and save your selection to a text file.


#14

I followed your directions and the .txt file looks the same. What do you want me to do with the file?


#15

Here is LBA 0 from my Win98SE drive:

http://www.users.on.net/~fzabkar/HDD/HDD1.txt

Can we see your MBR in similar format?


#16

Yes. Mine looks exactly like that using HxD, except the hieroglyphics are different order :).

Now what.


#17

I have the ONE and ONLY logical answer for all of the My-Book customers/owners.

OK - Three days ago the USB Mini connector Broke Off (It’s a flimsy design and this can happen to anyone)

I used Western Digital e-mail and phone support to get an answer to one question “Is the USB Card unique to the drive” hoping that they would say no.  Well they said “yes” it is unique to the drive - that is the USB card firmware is unique to the drive when you set it up.

WELL AFTER TALKING TO ASSOCIATES OF MINE AND LOOKING FOR VARIOUS WAYS TO RECOVER THE DATA - WHICH FRUSTRATED ME BEYOND COMPREHENSION,  I finalll went and bought another identicle size and model MyBook - removed the USB card and connected it to my old drive… and guess what… it worked.

The reason I took the risk (against WD Support) was that I was able to find this exact card on the spot market  from a seller in Hong Kong.  I thought “It can’t be unique to the drive if I can buy a replacement - and only the card”  By the way

this card I found was going to cost $125.00 .  Yeah, I know, it’s more then a whole new drive.

So, if you feel comfortable taking things apart you can do this yourself.  Or - find a good repair shop that will perform the work for you if you feel the slightest bit uneasy about working on your HD.

1.  Go buy the exact same model of MyBook that you have.

2.  Take it apart carefully and remove the USB card from the new drive.

3.  Connect the new card to your old drive.

4.  With your computer powered up, plug in your USB connections  THEN plug in the power to the drive.

5.  Don’t do anything, just let your computer do it’s thing - the re-orientation process took about three minutes and when it was completed, my paths-drive name-and ALL files were intact.

PHEEEEEEEWWWWWWWW!

I felt blessed.


#18

Congratulations liamiam.

I wonder if the “USB card firmware is unique to the drive when you set it up” … with a password???

Would you mind photographing the internal components and uploading the photos to a file sharing service? Knowing what’s inside would help us understand how the device works. I’m watching a second thread where an enclosure identifies itself as a “default Initio controller”.

MadatWD, could you upload your data to a file sharing service, eg RapidShare?


#19

No.  I can do that.  I am away from my office right now but I would be more than happy (happier) to meet your request when I get back… Sorry - please wait - sorry.

-Liam