Help My Book Live 2 remote access problem

My Book Live 2. I can;t reach remote access same like you people. Is there a solution or not.

I have been having trouble for weeks now with remote access to Pad.

I have sifted through dozens of threads on various forums with suggested solutions, but have had no success with solving the issue.

I can access photos with WDPhoto but WD2GO is the problem.

I keep getting “device offline”, " not accessible" messages.

Is there anyone out there that can assist me.

I have raised a case with WD support, but have had no response in over a week now.


I purchased a MyBookLive NAS drive last month because my old WD mybook stop working properly. I set it up such that I could access all my pictures, photos & videos from online devices like my laptop, iPhone and iPad. I then transferred all my data (1.2Tb of data in total) and was happily accessing the information as advertised.
2 Days ago my wife accidentally, unplugged the router, then turned it back on again. I had a e-mail warning about the network not being available, but I was expecting this due to the router being turned on/off.

Now when I try and access my NAS drive, it wont connect. When I go through the Dashboard, it says it has the latest firmware (02.32.06-006 : Core F/W) when I click on the Network Tab it says Internet Access: Good, but when I click on the remote access tab, it says Connection Status: Failed Cannot establish remote access connection. Make sure you are connected to the Internet. (Error 31520).

I have tried rebooting my drive through dashboard, no joy.  I then tried shutting down my drive, turning off my router, turning my router back on, letting it boot up completely and then turning the HD back on, but this still doesn’t work.

I have tried removing the tick from the remote access box and then ticking it again, it spends about 5 mins saying Connecting-Trying to establish a remote access connection… in the connection status but then comes up with the above error again.

My connection options are Automatic.

As I spent a LONG time transferring 1.2TB of data, I do not want to perform a factory reset and lose all this information. But I would like the ability to access my information from my iPad again, also I would like to add my wifes iPad but cannot get a remote code or access the drive via my p/w (which works for the dashboard) as it says device not available.

When I try and connect through my iPad (which I used to be able to do ) I get the message - Device Offline, Only local files are available.

I have not seen anything on the forums that seems to solve this porblem  I would also rather keep my connection set to automatic as I am not really confident about changing settings on my router.  Finally I am using Windows 7 home premium SP 1 fully up to date.

Anyone help please???

you could try the suggested route here