Help! Mount Issue and Files Not Showing Anymore

Help, I have a MyCloud that is about a year old (maybe a little less than a year). About a week ago I noticed that the drive wasn’t working, the light was red and it said that there was a mount issue when I tried accessing through the dashboard. I called WD support and they had me to a reset by pushing a paperclip in the back. After it rebooted, the light was now blue, but it shows that there is no space and I can’t see or access any files. I spoke to WD advanced support today and they tried manually connecting but couldn’t.
It seems that there is still a mounting issue or something similar going on.
My main concern is that all of my personal and work info is on this drive and most of it isn’t backed up anywhere else. I didn’t think that I would need a back up of a back up, especially since this drive isn’t that old.
I would appreciate any suggestions or advice to help me access my files. Thank you

There are some previous reports of mount problems. Here’s one, with their solution:

Backups are needed as soon as you put data on a HDD; they can fail at any time.

1 Like